I have a laptop with Intel GMA 4500M integrated graphics, 4GB of RAM and a 2.2GHz dual core processor with Ubuntu 12.04 64-bit. I recently bought the Humble Indie Bundle 5 and I was able to install and play LIMBO, Bastion and Sword and Sworcery, I haven't installed Psychonauts yet and I have installed but unfortunately cannot play Amnesia.

I choose the lowest possible settings but when I start a new game it just closes on me. Any suggestions?

  • I have installed bastion and amnesia by downloading the torrents and running the .sh files, not via the ubuntu software center. – Anthony Lorenzo Acuña Jun 5 '12 at 2:42
  • Same happens to me, i have Nvidia and installed Amnesia through the software center – Jeggy Jun 6 '12 at 21:18

I will copy and paste my answer to a similar question that was here

I was able to get my Intel Sandy Bridge working.

First you need to have mesa-utils installed

you need need the s3tc library installed, it allows the texture compression needed by mesa

search for and install


in the Software Center.

If you card can support it, the game will launch. There are several quality selections in the launch window that comes up so you can try low if medium doesn't work. Medium works for me, I haven't tried High as Medium is very nice.

I can tell you that apport seems to think that your gpu hangs so you may get the "System error encountered" box popping up but I had no hangs except when apport was gathering information and after I removed

apport, apport-gtk, apport-symptoms

I have been playing with no problems for the last 3-4 days. So if you can get it working you may have to uninstall those progrmas or disable apport to play without interruptions.

If you tell the launch window for Amnesia to detect your card it will tell you it's unsupported but as I said it is working fine on my Intel.

If your video card will support Amnesia this fix should work.

  • I just did "sudo apt-get install libtxc-dxtn-s2tc0" and now it works perfectly ! thanks :D – Jeggy Jun 14 '12 at 12:28
  • glad I could help, I can only take credit for finding the page that told me how to do it. It was driving me crazy as well, esp. as the developer had a very similar game that would run fine on my computer. – TrailRider Jun 14 '12 at 22:51
  • it worked for me too! – lpanebr Aug 22 '13 at 6:32

These steps WORKED! Thank you so much

  1. Installing mesa-utils

  2. Installing the s3tc library, which allows texture compression

I searched for and installed libtxc-dxtn-s2tc0 from the Ubuntu Software Centre


I downloaded and installed the files in this youtube video: http://m.youtube.com/#/watch?v=9klAxeQsHlQ&desktop_uri=%2Fwatch%3Fv%3D9klAxeQsHlQ

Now I can play Amnesia on Ubuntu 12.10. 2.2ghz dual core processor. 5gb ram. Intel GMA 4500M.

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Oyibo Dec 5 '12 at 7:47

Here is what a guy did to install the game: http://www.youtube.com/watch?v=RMq0BWMOdgc

  • 2
    A step by step guide with reference to the video if needed would be better than just an external link. – Bruno Pereira Jun 6 '12 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.