0

I am trying to set key bindings for my mouse buttons with xbindkeys and I'd like to set one of them to spread the windows as if I'd pressed Super+W but for some reason this one won't bind properly it just registers as a regular press of the w key. I've tried every other combination of super+__ and they all work fine and unfortunately CCSM no longer allows rebinding this combination in 12.04. Does anyone know why this one combination wouldn't work or how I can remap the spread windows action to another set of keys?

  • It appears that there are some key combinations that the system already uses that will only perform their system function even if the custom shortcuts allowed you to assign that code combination to a different function. Another example is Ctrl-Alt-C which is assigned to the calculator. I tried to assign that key combo to execute a different calculator and it wouldn't work. – fragos Jun 5 '12 at 7:16
0

Autokey-Qt might be able to map that key combo for you, however, Autokey will execute it and then the operating system will perform its task afterwards. This annoyed me enough that I moved my shortcut. :(

0

You can do this with CCSM (Compiz Configurations Settings Manager) under the "Scale" plugin.

  1. Install ccsm by typing this in a terminal:

    sudo apt install compizconfig-settings-manager

  2. Launch ccsm

  3. Scroll down to the Scale plugin and click it. It's under the Window Management section.
  4. Click on the Bindings tab.
  5. Find the mouse icon with the words Initiate Window Picker next to it.
  6. There is a button to the right of that which says Disabled (the default setting). Click that button.
  7. In the window that pops up, check the Enabled check-box.
  8. That window will expand with a bunch of options. Click the drop-down list at the bottom of the window that should say something like Button1.
  9. Select the button you want associated with this action. I use Button10, which is the "press-down" thumb button on my mouse.

Here are a couple useful things I do that make this a great tweak.

  1. Enable the Button Bindings Toggle Scale Mode check-box up at the top of the Bindings tab of the Scale plugin.
  2. I highly recommend binding the mouse button to Initiate Window Picker for All Windows (Shift-Super-W) instead of Initiate Window Picker (Super-W). This should bring in the windows from other workspaces as well.

Enjoy the your newfound efficiency! I rate this as one of my top 10 efficiency tweaks to Linux, I absolutely love it. The only thing I use the taskbar for any more is launching programs.

  • 1
    Have you tested this under 12.04 as was specified in the original question? If not would you be so kind as to incorporate the version you tested it on into your answer? Thank you for your consideration. – Elder Geek Feb 15 '17 at 19:28
  • 1
    This is actually a duplicate of this question (concerning Ubuntu 12.04). 12.04 Unity middle mouse activation of compiz window scaling It looks like it user jokerdino had it working on 12.04. Been doing this for years. Don't recall if I was doing it under 12.04. Done on 14.04 and 16.04. Keep in mind that Ubuntu 12.04 let you choose between a 2D desktop and a 3D desktop. If you logged in with the 2D option, you won't get Compiz features. Compiz requires 3D graphics acceleration. – SunnyDaze Apr 14 '17 at 20:57
  • 1
    I just verified the above solution works in Ubuntu 12.04 on my wife's laptop. However, if you log in with the 2D option, you will be able bind the mouse keys in CompizConfig Settings Manager, but the Scale plugin won't work when you press the mouse button until you log back in with the 3D option (the option that doesn't have 2D in it's name). – SunnyDaze Apr 17 '17 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.