0

I installed updates

On restart, apache2 yielded:

/usr/sbin/apache2: symbol lookup error: /usr/sbin/apache2: undefined symbol: apr_os_uuid_get

I'm reinstalling the apache2 while I await the obvious quick-fix answer.

Already tried updating the library

libaprutil1-dev is already the newest version (1.6.1-2ubuntu0.1)

12
  • By "updates" do you mean that you upgraded from Ubuntu 16.04 (or older) to something newer, and now Apache isn't working? This particular issue hasn't been an issue for most people for over five years 🤔
    – matigo
    Apr 26, 2023 at 9:18
  • i updated the linux libraries using apt-get update and it started happening
    – shivam
    Apr 26, 2023 at 9:22
  • what can be a possible solution to this, since reinstalling apache2 hasnt helped
    – shivam
    Apr 26, 2023 at 9:22
  • There is an insufficient amount of actionable data here. Is the 16.04 tag in your question accurate? If so, the only real solution is to upgrade your server to something newer. 16.04 has not been supported for almost two years ...
    – matigo
    Apr 26, 2023 at 9:39
  • I upgraded it to 18.04 LTS moments ago, still the same.
    – shivam
    Apr 26, 2023 at 9:44

0

You must log in to answer this question.

Browse other questions tagged .