4

I recently switched my Windows laptop over to Ubuntu 22.04, and I am trying to get Thunderbird working. The email I use is a University email, and they use Microsoft's servers (office365) and OAuth2 for authentication.

Thunderbird doesn't recognize my email address, so I have to set up all the mail servers manually. The issue is the drop down for authentication method only shows OAuth2 for the incoming server, not the outgoing. So I am able to read all the messages that get sent to me, but I have no means of replying.

I've seen online that many people have this issue sometimes with Thunderbird, but none of their fixes help. I've deleted the .thunderbird directory and restarted Thunderbird, and that hasn't worked. I've also run sudo apt remove thunderbird and sudo apt purge thunderbird then reinstalled it, but that hasn't worked either. I just can't seem to get OAuth2 to pop up.

I'd appreciate any help!

EDIT: Added better screenshots of the outgoing server settings with the authentication method dropdown open and closed.

Screenshot of open dropdown.

Screenshot of closed dropdown.

3
  • 1
    The image appears to me as if you did not specify a user name. That will likely be required also for a two factor login.
    – vanadium
    Commented Apr 26, 2023 at 7:50
  • @vanadium unfortunately, I had already entered my username. I reattached screenshots showing the full outgoing server settings that includes my username now.
    – cameronpoe
    Commented Apr 26, 2023 at 15:53
  • I see. The user name is likely grayed out because "No authentication" is selected.
    – vanadium
    Commented Apr 26, 2023 at 16:57

5 Answers 5

10

First, I don't know if you noticed, but you have a typo in your server name. You wrote smpt.office365.com instead of smtp.office365.com.

Then, this is a known bug it seems. You can force Thunderbird to propose OAuth2 like this:

  • set your outgoing server with "No authentication"
  • close and re-open Thunderbird
  • then go to Thunderbird settings
  • look for the config editor (very end of the "General" tab for me). It opens a new tab with a search bar.
  • in this search bar, type "mail.smtpserver". It should display all your SMTP servers settings, with a number associated to each of them. Locate the number of your Outlook server. Let's say it's "99" for the example.
  • look for the parameter mail.smtpserver.smtp99.authMethod (with "99" replaced with the number corresponding to your SMTP server), change its value from 1 (code for "No authentication") to 10 (code for "OAuth2"), and save it with the tick button on the right advanced config editor with the mail.smtpserver.smtp99.authMethod setting
  • exit the config editor, close and reopen Thunderbird
  • go back to the account settings, your server should now be set to OAuth2. Complete the missing information (probably your username)
  • try to send an email from your Office 365 account. It should trigger the OAuth2 authentication procedure.
1
  • 2
    Thanks for catching the typo -- that fixed it! When I retried setting up Thunderbird in my comment to Bryan Bemley, I must have typed it in right. I just checked by setting up Thunderbird a second time and when I used the typo version it didn't pop up OAuth2, but the correct spelling did pop up the OAuth2 option.
    – cameronpoe
    Commented Jun 12, 2023 at 21:46
1

after changing smtp-mail.outlook.com to outlook.office365.com

ok-ing out of the 'edit smtp server' dialog, and then re entering 'edit smtp server'

the OAuth2 option is available under STARTTLS

Thunderbird 115.12.2 (64-bit)

0

After you add the username, accept the settings. Then, go back into the new server settings you created. The oAuth2 option should be available. Annoying fix, but it works. I've just done it.

2
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented May 3, 2023 at 14:34
  • Thanks for the hint! Ended up going back to Thunderbird after about a week and it worked first try -- didn't have to go into server settings or anything to get the OAuth2 option. Really weird, I still don't know what I did differently now than the last dozen times I did this.
    – cameronpoe
    Commented May 7, 2023 at 4:08
0

Try the following steps:

  1. Add your Microsoft-365 email account by following this thread.
  2. Use "normal password" instead, and if everything is correct (ingoing/outgoing settings, including the password) it will try to authenticate and it will fail.
  3. Then if you go back into the settings OAuth2 should be available as Authentication method in the dropdown list.
0

Oauth works with SLL/TLS and you have STARTTLS selected for cryptographic protocol. Change it to SSL and there is the option for Oauth

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .