4

I've just upgraded my Ubuntu 22.10 to 23.04 and the upgrade went well but, just after the reboot, Gnome Shell didn't load any extension, even Ubuntu Dock. Using journalctl to see what could be happening only messages indicating that extensions are missing or are invalid is shown, indicating "state 99" as the error code.

To try to fix it I've reinstalled nvidia-drivers and upgraded to version 525. Also, I tried to use only Intel graphics card, tried to choose Ubuntu session on Xorg, Ubuntu session on Wayland and, finally, Ubuntu with Gnome Classic (Xorg), and using this session all extensions were loaded.

This error is related to this another one.

Edit: As indicated by Ross Dobson, removing user extensions and reboot fixes the problem. Then, all extensions must be reinstalled. Fortunately, all extensions' configuration is kept.

Finally, I'm not sure but thinking about the problem I guess that it came because I had system extensions overridden by user extensions, like Desktop Icons NG.

Hope Canonical fix this problem.

3
  • I assume you were not too quick, and see extensions disabled after each reboot? Else, try reenabling the extension, then see whether they remain turned on after rebooting. To me, a more obvious way of troubleshooting would be to first see if the problem persists after disabling all my custom extensions. Only if the issue remains then would I start to fiddle with system files.
    – vanadium
    Apr 25, 2023 at 9:33
  • Yes, @vanadium. All extensions are disabled after every reboot, but if I try to enable them, they are enabled (according to gnome-extensions application) but they don't work (only appear "state 99" errors using journalctl, as said before). Thanks for your comment.
    – Diego
    Apr 25, 2023 at 9:51
  • Why don't you provide information on which extensions are involved? Are these all default extensions, or are there also extensions you installed yourself? Another idea for debugging: temporarily create a new account and see if issues reproduce there.
    – vanadium
    Apr 25, 2023 at 11:11

3 Answers 3

5

Remove any existing extensions.

cd ~/.local/share/gnome-shell/
rm -rf extensions

Then log in again and it now should load the desktop successfully. I'm not sure why this situation occurred in the first place, but this fixed it on my machine.

Note that you will need to re-install any custom extensions again, from http://extensions.gnome.org.

4
  • It worked perfectly. Thank you very much.
    – Diego
    Apr 26, 2023 at 20:20
  • Probably removing the extensions using the Extensions tool or the Extensions website, then reinstalling them would work just as fine.
    – vanadium
    Apr 27, 2023 at 7:31
  • @vanadium I found that removing it through the Extensions website didn't work. In the Extensions manager itself, extensions were showing as globally disabled, with the toggle to turn them on greyed out (and consequently, each individual extension greyed out. I don't think the extensions system was properly loading at all. That's why I had to use the terminal. Apr 29, 2023 at 16:02
  • It is the solution. Thank you.
    – PhJ
    Dec 16, 2023 at 8:29
1

Removing "[email protected]" from extensions folder solved the problem

1
  • This is my solution, I built it from sources without using the ubuntu_install.sh and it seems to cause some issue (even tho I uninstalled the global gnome-shell-extension-desktop-icons-ng package). It no longer starts with some grayed ou extensions now. Thanks
    – Quentium
    Jan 19 at 8:47
0

I was able to get an extension working again by editing the metadata.json file in the "shell-version" section to include "44". Logout and back in and the extension was working. This was a simple extension so this may not work for others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .