3

Upgraded today to Kubuntu 23.04 from 22.10, simply using the prompt that popped up in the bottom right of the screen (warning me that 22.10 would reach EOL in less than 90 days).

All seemed to go well, but upon rebooting the system to complete installation, I couldn't seem to continue booting past the manufacturer's screen (which in my case, prompts me to unlock my fully encrypted drive).

I turned out to be able to get a TTY, logged in and tried to start X manually by running startplasma-x11. This failed with the following error:

meladoro@localhost:~$ startplasma-x11
$DISPLAY is not set or cannot connect to the X server.

Trying startx also fails:

meladoro@localhost:~$ startx
X.Org X Server 1.21.1.7
X Protocol Version 11, Revision 0
Current Operating System: Linux localhost 6.2.0-20-generic #20-Ubuntu SMP PREEMPT_DYNAMIC Thu Apr  6 07:48:48 UTC 2023 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-6.2.0-20-generic root=/dev/mapper/vgkubuntu-root ro quiet splash vt.handoff=7
xorg-server 2:21.1.7-1ubuntu3 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.42.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 25 10:31:16 2023
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
Fatal server error:
(EE) no screens found(EE) 
(EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.

Finally, trying startplasma-wayland worked, and got me to the graphical environment.

Of course, this is not suitable, as I understand that the Wayland session is there for testing purposes only, and not actually supported. I would like to restore the normal login behavior, with a graphical login screen that starts a Xorg session by default.

EDIT: Here's the output of lspci:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
04:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)

Someone (without knowing my hardware configuration) suggested this issue may be related to the NVIDIA proprietary drivers. As you can see above, I do have an NVIDIA graphics controller (this is an Asus N56 series laptop). Browsing around, I found the following link: https://wiki.archlinux.org/title/NVIDIA/Troubleshooting—and it does have something that looks relevant to my situation (see section 1.5) but I cannot yet quite understand how to use it to troubleshoot.

Any ideas or pointers are welcome. Thank you very much.

3 Answers 3

3

I had a similar issue upgrading to Ubuntu 23.04 on a laptop with both intel hd and nvidia graphics cards. I found that removing the nvidia drivers and installing the open source nouveau driver allowed the system to boot normally. I just CTL-Alt-F2 to get a terminal and log in. Then used the following commands:

sudo dpkg -P $(dpkg -l |grep nvidia-driver | awk '{print $2}')
sudo apt autoremove
sudo apt update 
sudo apt upgrade
sudo apt install xserver-xorg-video-nouveau
shutdown -r now
2
  • Thank you. Came here to close this question and report exactly the same thing you said. I ended up realizing that my legacy NVIDIA card is no longer supported, and it does not work with the latest 390 driver (which apparently will no longer be updated). It looked like it might be possible to get it to work by reverting to an earlier kernel, or some other workaround, but I too decided to switch to nouveau for now. Later I may reinstall the LTS release of Kubuntu, which should give me plenty of time to finally upgrade to more recent hardware, while still using the proprietary drivers.
    – meladoro
    Commented Apr 29, 2023 at 7:55
  • meladoro which card do you have? I'm currently in hell with this issue, can't get nouveau working either.
    – dez93_2000
    Commented May 16, 2023 at 21:35
0

I am encountering the same problem (with the very same graphic card) and I found that booting into recovery mode and then booting from the recovery prompt circumvents the problem. Any idea on why that happens?

1
  • Hi and welcome to Ask Ubuntu! It feels like this is more of a comment (with a question) than an answer, so you should have perhaps considered putting it in a comment unless it really is the only solution. Commented Jun 12, 2023 at 16:26
0

@meladoro Nice Comment on the 390 drivers.

sudo apt-get purge nvidia*

sudo apt install xserver-xorg-video-nouveau

sudo shutdown -r now

After Nouveau was the driver in use, working like a charm thanks.

zeus@Pandion:~$ lspci -nnk | grep -iA2 vga

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
    Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f4]
    Kernel driver in use: i915

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [NVS 5400M] [10de:0def] (rev a1)
    Subsystem: Lenovo GF108M [NVS 5400M] [17aa:21f4]
    Kernel driver in use: nouveau

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .