1

I wanted to control my fan speed with the fancontrol package. I soon run into this problem:

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

After a bit of research, I realised that I need to add acpi_enforce_resources=lax to /etc/default/grub

Unfortunately, this did not solve my problem. I did more research and checked my sensors, which gave me the following output:

Adapter: ISA adapter
Package id 0:  +37.0°C  (high = +80.0°C, crit = +100.0°C)
Core 0:        +33.0°C  (high = +80.0°C, crit = +100.0°C)
Core 4:        +33.0°C  (high = +80.0°C, crit = +100.0°C)
Core 8:        +34.0°C  (high = +80.0°C, crit = +100.0°C)
Core 12:       +34.0°C  (high = +80.0°C, crit = +100.0°C)
Core 16:       +33.0°C  (high = +80.0°C, crit = +100.0°C)
Core 20:       +34.0°C  (high = +80.0°C, crit = +100.0°C)
Core 24:       +34.0°C  (high = +80.0°C, crit = +100.0°C)
Core 28:       +33.0°C  (high = +80.0°C, crit = +100.0°C)
Core 32:       +36.0°C  (high = +80.0°C, crit = +100.0°C)
Core 33:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 34:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 35:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 36:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 37:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 38:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 39:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 40:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 41:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 42:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 43:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 44:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 45:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 46:       +35.0°C  (high = +80.0°C, crit = +100.0°C)
Core 47:       +35.0°C  (high = +80.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +27.8°C  (crit = +105.0°C)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +39.0°C  

nvme-pci-0300
Adapter: PCI adapter
Composite:    +45.9°C  (low  =  -0.1°C, high = +79.8°C)
                       (crit = +81.8°C)
Sensor 1:     +45.9°C  (low  = -273.1°C, high = +65261.8°C) 

As one can see, there is no fan information. When running sensors-detect and agreeing to everything, I get the following output:

To load everything that is needed, add this to /etc/modules:
#----cut here----
# Chip drivers
coretemp
#----cut here----
If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones!

I have the impression that there should be another driver listed after coretemp, but could not find any solution for that. Therefore, I kindly ask the forum for help :-)

I have a fresh installation of Ubuntu 22.04 on my computer. I use the MSI MPG Z790 motherboard. Further, I have 2 RTX3090 GPUs with the 525 driver.

Edit: Here the output of the super I/O section from the sensors-detect command.

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): y
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      No
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               Yes
Found unknown chip with ID 0xd592
2
  • post the output of the Super I/O section when running sensors-detect
    – rtaft
    Commented Apr 23, 2023 at 22:54
  • @rtaft Thank you for your help. I have added the information to the end of the question.
    – chrichro
    Commented Apr 25, 2023 at 1:05

1 Answer 1

0

The key is the information here

Found unknown chip with ID 0xd592

When you search for that exact error, you will find some resources to help. It looks like this board has a I/O Controller NUVOTON NCT6687-R Controller Chip. The good news is that drivers for older Nuvoton controllers will probably work with it if we manually load them. You can see the nct drivers available https://github.com/torvalds/linux/tree/master/drivers/hwmon

Inside nct6683.c we see

#define SIO_NCT6687_ID      0xd590

It looks like support was added for it in 5.11 under nct6683, and Ubuntu 22.04 started with 5.15 and now uses 5.19 so it should work in all 22.04 versions. It must be an issue with sensors-detect.

Test it out with

sudo modprobe nct6683

and see if it shows up in sensors. If it works, simply add nct6683 on it's own line in /etc/modules

8
  • Thank you very much. I tried it out but it did not work. So I assume it is a driver problem. I checked on the MSI page, but they did not provide any Linux drivers. Do you have any suggestion where else I could source another driver, given that the old one also doesn't work?
    – chrichro
    Commented Apr 27, 2023 at 9:19
  • Did you rebuild grub after adding lax to /etc/default/grub?
    – rtaft
    Commented Apr 27, 2023 at 12:05
  • You can also try sudo modprobe -f nct6683. There is a check in the driver to see if the customer_id for the board matches what it expects (0x201 for MSI). It's possible it's using something else, in which the -f will bypass it.
    – rtaft
    Commented Apr 27, 2023 at 15:03
  • I've done rebuild on grub and tested the sudo modprobe -f nct6683 command. Still not working.
    – chrichro
    Commented Apr 28, 2023 at 10:21
  • does grep nct /etc/sensors3.conf have an entry for nct6683 or nct6687? I encountered this chip previously on here on an MSI Z590 and a simple modprobe worked, odd that it's not working here.
    – rtaft
    Commented Apr 28, 2023 at 12:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .