0

I have a recent Build of Ubuntu 20.04, Fresh installation 3 months ago, Installed on an SSD (No Boot ZFS), where I created 2 zpools: one 'zombiepool2' 4 x 2TB (not, very new drives), second 'zombiepool' 3 x 3TB, both raidz1 for PLEX server One morning there was a clicking sound on the 4 drive pool, and one drive is shown as FAILED where the pool is also FAILED, my problems is: 1-I swapped bad drive for an empty one and tried replacing it, -but Drive changed status to UNAVAIL, and pool also to UNAVAIL 2-I put back bad drive, and inserted the new empty one on an open SATA port, drive status changed to FAILED and also on zpool changed to FAILED

I will show my terminal outputs below, but my question is HOW do i Replace the drive if the command says is unable to use the pool

-----sudo zpool status pool: zombiepool state: ONLINE scan: scrub repaired 0B in 07:17:56 with 0 errors on Sat Apr 1 17:25:43 2023 config:

NAME        STATE     READ WRITE CKSUM
zombiepool  ONLINE       0     0     0
  raidz1-0  ONLINE       0     0     0
    sde     ONLINE       0     0     0
    sdf     ONLINE       0     0     0
    sdg     ONLINE       0     0     0

errors: No known data errors --------sudo zpool import pool: zombiepool2 id: 2181955902400174884 state: FAULTED status: One or more devices contains corrupted data. action: The pool cannot be imported due to damaged devices or data. The pool may be active on another system, but can be imported using the '-f' flag. see: https://openzfs.github.io/openzfs-docs/msg/ZFS-8000-5E config:

zombiepool2                  FAULTED  corrupted data
  sdb                        ONLINE
  sdc                        FAULTED  corrupted data
  ata-ST32000542AS_5XW020AR  ONLINE
  ata-ST32000542AS_5XW01YSD  ONLINE

----- my available empty drive is ......... Model WDC WD2003FYPS-27Y2B0 (04.05G11), Serial N:WD-WCAVY6043324 ......... GUID Partition Table, Unallocated Space /dev/sdi

------sudo zpool replace -f zombiepool2 /dev/sdc /dev/sdi ------(tried with and without -F -f) and get cannot open 'zombiepool2': no such pool

What are my options to save the pool?

********ADDED ZDB command results *******

zombiepool:
    version: 5000
    name: 'zombiepool'
    state: 0
    txg: 1297882
    pool_guid: 17864338163211157409
    errata: 0
    hostid: 1372433909
    hostname: 'plexzombieU'
    com.delphix:has_per_vdev_zaps
    vdev_children: 1
    vdev_tree:
        type: 'root'
        id: 0
        guid: 17864338163211157409
        create_txg: 4
        children[0]:
            type: 'raidz'
            id: 0
            guid: 2716189947926612760
            nparity: 1
            metaslab_array: 132
            metaslab_shift: 34
            ashift: 12
            asize: 9001735028736
            is_log: 0
            create_txg: 4
            com.delphix:vdev_zap_top: 257
            children[0]:
                type: 'disk'
                id: 0
                guid: 11774464606619835771
                path: '/dev/sde1'
                devid: 'ata-ST3000DM001-1E6166_Z1F591S9-part1'
                phys_path: 'pci-0000:01:00.1-ata-1.0'
                whole_disk: 1
                DTL: 273
                create_txg: 4
                com.delphix:vdev_zap_leaf: 258
            children[1]:
                type: 'disk'
                id: 1
                guid: 9891655099731410770
                path: '/dev/sdf1'
                devid: 'ata-ST3000DM001-1CH166_Z1F65800-part1'
                phys_path: 'pci-0000:01:00.1-ata-2.0'
                whole_disk: 1
                DTL: 262
                create_txg: 4
                com.delphix:vdev_zap_leaf: 259
            children[2]:
                type: 'disk'
                id: 2
                guid: 15970182034792832750
                path: '/dev/sdg1'
                devid: 'ata-ST3000DM001-1E6166_Z1F4L1NW-part1'
                phys_path: 'pci-0000:01:00.1-ata-5.0'
                whole_disk: 1
                DTL: 10
                create_txg: 4
                com.delphix:vdev_zap_leaf: 260
    features_for_read:
        com.delphix:hole_birth
        com.delphix:embedded_data
4
  • 1
    It looks llike zombiepool2 was not created as a raidz; see the structure of zombiepool where there's a raidz1-0 vdev grouping the disks; no such thing is seen in the zombiepool2 status. (The "zdb" command prints a much more detailed view of the zpool structure, try it.) If it's not a raidz (or a mirror), then it's just a bunch of disks, and I don't think there's any way to recover.
    – rfm
    Commented Apr 17, 2023 at 3:40
  • Added zdb result to QUESTION and there is the command i used to create (still in history) Pool1
    – chuygb
    Commented Apr 18, 2023 at 19:46
  • Added zdb result to QUESTION-- saved prev comment by mistake and there is the command i used to create both pools, could not find them in history --Pool1--- zpool create -f zombiepool raidz1 /dev/sda /dev/sdb /dev/sdc --Pool1- was copy & paste + change of drive paths, if i skipped by mistake the raidz1 keyword, that creates a JBOD?
    – chuygb
    Commented Apr 18, 2023 at 20:01
  • @chuygb yes, if you skipped the raidz1 keyword, you just create a ZFS JBOD with no parity. Commented Apr 22, 2023 at 9:27

1 Answer 1

0

@rfm is correct in the comments. As it's evident from your zpool status command, zombiepool2 was not created as a raidz1. Hence, you can't replace disks or recover data.

So unfortunately the bad news: All data on zombiepool2 are lost, unless you're willing to spend a considerable sum on data recovery.

If you decide to recreate zombiepool2 again, make sure to create it as a raidz1, so that you can recover data in case of a failing disk. The command would be as follows:

zpool create -m /path/to/mountpoint zombiepool2 raidz /dev/sda /dev/sdb /dev/sdc /dev/sdd

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .