0

I am running Kubuntu 22.10 with everything up to date. As soon as I install any (proprietary) nvidia driver, I cannot boot into a graphical system anymore.

System Info:

  • Kubuntu 22.10
  • Kernel 5.19.0-1021-lowlatency
  • GPU: GeForce GTX 1660
  • DE: Plasma 5.25.5 (X11)

When I boot normally, using the nouveau driver, everything works, that is except for games that apparently require the proprietary driver. As soon as I install any nvidia driver (I tried nvidia-driver-525 and -515), I can't boot into the desktop. I am thrown into the boot screen with a message saying:

nvidia-gpu 0000:06:00.3: i2c timeout error e0000000

This however seems (according to other posts I've seen) not to be the source of the problem. iirc, I have seen this screen a couple of times before, but then the DE still loaded.

The system started to behave this way when I installed a kernel upgrade some time ago. On the reboot after that, my system did not boot. I "solved" it by opening tty (Ctrl+Alt+F2) and uninstalling the nvidia packages from there. I cannot tell for sure, but I might have accidentally rebooted my PC before all the kernel upgrades succeeded, I don't remember.

I have so far always been able to get back to the current semi-functional state without an nvidia driver by uninstalling all nvidia-related packages through tty.

I have tried different ways to install the driver, including apt and ubuntu-drivers. The kubuntu-driver-manager utility does not allow me to select a driver for some reason, it prints python errors to the terminal, but that's likely a different issue.

All tools report the same driver versions, e.g. for nvidia-driver-525: VERSION 525.105.17-0ubuntu0.22.10.1

I have currently no packages matching nvidia installed (I did apt purge). My Windows dual boot reports that the GPU works as expected.

I tried apt --reinstalling the linux-headers and then installing the driver, but that didn't change anything.

Are there any ways I can easily get back to a previous kernel to try if that's the issue?

Does it make a difference through which system tool I install the driver? (apt / ubuntu-drivers / kubuntu-driver-manager [broken!]). Should I try installing the driver through the NVIDIA homepage? The version code is the same (525.105.17).

6
  • For an older kernel, select the grub menu "Advanced", then select the older kernel. Don't use the Nvidia site drivers, they typically break every update. Python problems on the driver install indicate you might be using the 525-open version, avoid that one (or any "-open" driver, they cause name-parse problems.
    – ubfan1
    Commented Apr 14, 2023 at 21:34
  • What you are using is not a standard kernel. Where did you get this from?
    – David
    Commented Apr 15, 2023 at 7:47
  • Typically you have to be well experienced to get kernel, python (required by apt, apt-get) and similar component replacements to work to 100% - if you do not have that level of experience, avoid doing anything else than update by use of apt or apt-get (normal automated system updates)
    – Hannu
    Commented Apr 15, 2023 at 14:21
  • I did not install that kernel or anything else from somewhere else, I just got it through update upgrade. What I did do is install some packages that were kept back in apt upgrade. Commented Apr 15, 2023 at 18:51
  • I tried booting into 5.19.0-38-generic, too. Didn't boot at all :D I did a fresh install, I am now on 5.19.0-38-generic with nvidia-driver-515, everything works. Closing this. Thank you all Commented Apr 15, 2023 at 21:40

1 Answer 1

0

I did a fresh install, I am now on 5.19.0-38-generic with nvidia-driver-515, everything works.

Everything means including kubuntu-driver-manager for some reason.

1
  • Well a fresh install would seem to be a good idea on the surface but you never did solve the problem.
    – David
    Commented Apr 16, 2023 at 9:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .