After newest kernel update I have lost my sound card. There is only sound via USB adapter. My headphones or speakers are working only through this device. The sound setting widget doesn't show any sound card device beside USB. I have updated ALSA driver from launchpad and also I have removed the ~./pulse directory, I have tried gnome-alsamixer ...but my sound card is just gone. I tred to find out if that is some hardware issue or if that is this unlucky kernel update. Take a look on this output of:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh


Here is the alsa-base.conf (with included blacklist):

and output of:

grep "Codec:" /proc/asound/card*/codec*
grep: /proc/asound/card*/codec*: No such file or directory

What else can I provide to find out what's wrong?

  • please attach the output of lspci in your question.
    – Samik
    Jun 4 '12 at 17:34
  • oh sure, I forgot that: pasteall.org/32588
    – user43484
    Jun 4 '12 at 18:27
  • 1
    to complete this report: i had only on-board soundcard/chip.....
    – user43484
    Jun 4 '12 at 18:41
  • There is no audio device detected in the lspci output, so the sound hardware is not detected, have you got any indication in any other ways that the sound chip may be malfunctioning?
    – Samik
    Jun 4 '12 at 18:48
  • To be sure, what is the output of lsmod | grep snd?
    – Samik
    Jun 4 '12 at 18:51

Based on the information you have provided so far, it appears like the driver module for your internal sound-card has been blacklisted.
You said that Ubuntu can detect and work with the sound card if you boot from Live CD. So spend the effort to boot from the Live CD again and do a lsmod | grep snd there, in this way you'll be able to know what extra modules are loaded there for your internal sound-card.

Then come back to your Ubuntu installation.

Check the file /etc/modprobe.d/blacklist-oss.conf and search there for those missing modules and if found comment them out by placing a # before them.
Finally perform sudo modprobe <missing modules> to load them into kernel.

  • excuseme, I dont get clear in comparison between this: pasteall.org/32626 (lsmod | grep snd ) and this: pasteall.org/32631 (etc/modprobe.d/blacklist-oss.conf). There is also soundcard in blacklist...that confusing me...could you help me to chceck it out? Thank you very much!
    – user43484
    Jun 5 '12 at 16:54
  • May I know the make/model of your sound card?
    – Samik
    Jun 5 '12 at 17:08
  • i have on board chip called: CM6501
    – user43484
    Jun 5 '12 at 17:33
  • 1
    Oh, that one is a USB sound card and I should have informed you to search it with lsusb, not lspci. Also this explains your provided data. From the very first o/p of alsa-info.sh, it's sure that your USB sound card is there and detected, with drivers. Just try alsamixer instead of gnome-alsamixer, if it detects your sound card, you can select your sound card with F6.
    – Samik
    Jun 5 '12 at 18:23
  • okay, that must be the problem, now i found my card...you are right, this is usb sound...and i could switch it on with alsamixer. but still I have no sound. So it is broken hardware. :(( Thank you very much for the help. I have learned a lot with your help. This is the best support portal in Www
    – user43484
    Jun 6 '12 at 14:46

Can you try this, that i used to solve a similar issue:

sudo modprobe snd-hda-intel

and add a line with snd-hda-intel at the end of /etc/modules.

I think this can solve your issue.

  • no, this solution dosn't work for me...so sorry :(
    – user43484
    Jun 5 '12 at 16:59

perhaps try this link http://www.mysamplecode.com/2012/05/no-soundcards-found-linux-mint-12.html?showComment=1390338718155#c4449143529292145936

worked for me !

Open a terminal (Applications -> Accessories -> Terminal) and type

sudo gedit /etc/default/grub

and then change the line from



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs"

Save the file.

After saving the file run update-grub

sudo update-grub

Restart the Machine !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.