I was running an 11.10 virtual machine on VMWare Workstation 7.1.5 build-491717.

I tried to upgrade the other day to 12.04. After everything was downloaded and installed, the system asked to be booted.

I've confirmed, and since then I've never been able succeed loading the system. When I boot, the screen shows nothing but a blinking cursor, and my caps-lock seems to repeatedly turn on and off. (which freaked me out :-) )

When I try to load my previous system (11.10), it manage to load, but everything is strange+no network connection.

Does anyone familiar with the issue? I've read some posts but it seems to be ages ago and non-relevant.

The gist of the panic from the screenshot is:

VFS: cannot open root device sda1
Please append correct root= boot option
Available partitions are: sr0 only
Kernel panic: VFS: unable to mount root fs

Never had problems before. In fact, Linux always ran better on the VM than the MS-win7. I'm not such a linux expert - nooB treatment would be preferred :-D


Physical System:

  • i5 2.66 quad, 12 GB ram
  • Graphic card (sux) nVidia 210
  • OS, win7 Ultimate.

I've tried installing the VM toolkit, so I can gain some extra features, but it didn't succeed as well, so my guess is nothing was installed.

The console output when TRYing 2 boot on recovery mode:


@izx, What am I suppose to do with it? :-) What do I need to do to fix the sda1 device? Is this a VM issue? Should I need to copy the settings as appeared on the previous version?

Edit Tried to run update-initramfs as @psusi suggested, but got another error. Apparently, my /lib/modules/ has nothing in it. I tried copying the modules.dep from another kenrnel (previous 1) but nothing. Here's the console output.

Dismissed, final solution: fresh install.

  • Are you able to boot in to recovery mode (press shift right before your OS would boot)? Jun 4, 2012 at 13:19
  • Did you install any extra vmware kernel modules or anything of that sort on 11.10? What OS is your physical host running?
    – ish
    Jun 4, 2012 at 13:36
  • @izx, 10x 4 the replay.. Now, what am I suppose to do with it? :-) What do I need 2 do to fix the sda1 device? Is this a VM issue??
    – OBY
    Jun 4, 2012 at 16:03

1 Answer 1


It looks like your new kernel is missing its initramfs. If you can boot the old kernel, then run sudo update-initramfs to generate one.

  • 1
    The OP indicated they are not very adept with such things; can you explain how to do so?
    – nanofarad
    Aug 18, 2012 at 17:09
  • If OP isnt't capable to open a simple terminal, he should probably not try to administrate a computer.
    – paladin
    Jun 29, 2021 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.