0

I am unable to enable Bluetooth on my system. I am running kernel version: 5.19.0-38-generic on Ubuntu 22.04LTS; with the following info for my bluetooth/wifi module: link(USB 0489:e069). It seems to indicate this is not supported by Linux at the time of writing. I am wondering how to track if there is any sort of progress being made to include support for this device in the 6.2 kernel.

Additional requested information:

[    0.083001] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.244580] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.253788] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-7f] only partially covers this bridge
[    2.589070] [drm] Loading DMUB firmware via PSP: version=0x05000500
[    2.589530] [drm] Found VCN firmware Version ENC: 1.24 DEC: 2 VEP: 0 Revision: 0
[    2.589533] amdgpu 0000:0b:00.0: amdgpu: Will use PSP to load VCN firmware
[    4.628019] Bluetooth: Core ver 2.22
[    4.628068] NET: Registered PF_BLUETOOTH protocol family
[    4.628070] Bluetooth: HCI device and connection manager initialized
[    4.628073] Bluetooth: HCI socket layer initialized
[    4.628075] Bluetooth: L2CAP socket layer initialized
[    4.628078] Bluetooth: SCO socket layer initialized
[    4.867270] mt7921e 0000:08:00.0: WM Firmware Version: ____000000, Build Time: 20221227123243
[    5.046049] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.046051] Bluetooth: BNEP filters: protocol multicast
[    5.046054] Bluetooth: BNEP socket layer initialized
[    6.777901] Bluetooth: hci0: Opcode 0x c03 failed: -110
07:00.0 Ethernet controller [0200]: Intel Corporation Ethernet Controller I225-V [8086:15f3] (rev 03)
        DeviceName: Intel I225-V LAN
        Subsystem: ASUSTeK Computer Inc. Ethernet Controller I225-V [1043:87d2]
        Kernel driver in use: igc
        Kernel modules: igc
08:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:0616]
        Subsystem: Foxconn International, Inc. Device [105b:e0cd]
        Kernel driver in use: mt7921e
        Kernel modules: mt7921e
4
  • Yes I am on Ubuntu 22.04 LTS
    – cogle
    Commented Apr 5, 2023 at 3:21
  • 3
    The 6.2 kernel is currently used by Ubuntu lunar which will be 23.04 when released; after release that kernel will become the edge kernel of 22.04, which after testing will become the HWE kernel stack prior to the release of Ubuntu 22.04.3 LTS (I was going to add jammy release schedule, but no date is set yet for 22.04.3, but even then it's available some time before then via install of the -edge kernel)
    – guiverc
    Commented Apr 5, 2023 at 3:30
  • 1
    Please edit to include results from terminal for sudo dmesg | egrep -i 'blue|firm'; lspci -nnk | grep -iA3 net
    – Jeremy31
    Commented Apr 5, 2023 at 21:44
  • @Jeremy31 I have updated to include output from the command you posted.
    – cogle
    Commented Apr 7, 2023 at 5:31

2 Answers 2

0

You can test this to see if it makes the Bluetooth work. Secure Boot needs to be disabled, check mokutil --sb

sudo apt install git dkms
git clone https://github.com/jeremyb31/bluetooth-5.19.git
cd bluetooth-5.19
make -j4 -C /lib/modules/$(uname -r)/build M=$(pwd) modules
sudo mv /lib/modules/$(uname -r)/kernel/drivers/bluetooth/btusb.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/btusb.bak
sudo mv btusb.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/btusb.ko

Reboot, if it works file a Ubuntu bug against package linux and include results from terminal for sudo cat /sys/kernel/debug/usb/devices | awk '/e069/' RS=

Info on filing bug report https://ubuntuforums.org/showthread.php?t=1011078

0

I can confirm that this chipset works with Ubuntu 23.04 with its default 6.2 kernel.

I had the same error when I installed Ubuntu 22.04 LTS on a new workstation. The computer has the same chipset as that reported by cogle in their question:

Network controller [0280]: MEDIATEK Corp. Device [14c3:0616]
Subsystem: Foxconn International, Inc. Device [105b:e0cd].

My workstation reported the same error:

Bluetooth: hci0: Opcode 0x c03 failed: -110

I have since upgraded the system to Ubuntu 23.04 and Bluetooth now works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .