What I tried

sudo service NetworkManager status

NetworkManager is active running.

sudo service systemd-resolved start

Got error:

Failed to restart systemd-resolved.service: Unit systemd-resolved.service not found

My /etc/resolv.conf doesn’t exits。

sudo ln /usr/bin/resolvectl /usr/bin/systemd-resolv

Not working because /usr/bin/resolvectl not exists

Then I reinstalled systemd

sudo apt reinstall systemd

Unfortunately everything is still the same as above.

Related issues

No one works for my case.

DNS issue after upgrading to 22.10

Upgraded to 22.04.01, DNS didn't work, tried to fix, now Ethernet doesn't work

  • "My /etc/resolve.conf doesn’t exits" I believe it is /etc/resolv.conf Let's take a look at: ls -al /etc/resolv.conf Welcome to Ask Ubuntu.
    – chili555
    Commented Apr 3, 2023 at 13:49
  • @chili555, thanks, it is a typo, fixed. Commented Apr 4, 2023 at 1:18

1 Answer 1


It seems the systemd-resolved is not included in systemd in Ubuntu 20.10, after upgrading, I installed it manually,

sudo apt install systemd-resolved

Now everything works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .