3

I had my second monitor on the right side of my laptop before, and I had no problem rotating the second monitor using keyboard shortcuts. The commands I use are:

xrandr --output HDMI-1 --rotate left

and

xrandr --output HDMI-1 --rotate normal

When the second monitor is rotated, it looks like this in Settings

enter image description here

Due to new apartment and table, I have to put my monitor now to the left side of the laptop. Now when I use the shortcut, it looks like this in the settings:

enter image description here

There is a gap between the monitors, and it feels terrible working with it. And if I move the second monitor in the settings to close the gap, then it works fine. But if I rotate the monitor back, the monitors overlap, and that's even more terrible.

Strangely if I change the orientation of the second monitor in the settings, not using the shortcuts, it works fine. I also noticed that in settings I have to set the second monitor to "Portrait Right", the opposite of the option in xrandr.

Does anyone have an idea how to fix my shortcuts?

1 Answer 1

3

I just found it out myself. Now I add the flag --left-of eDP-1 (my laptop display) to both commands, and it works beautifully. So:

xrandr --output HDMI-1 --rotate left --left-of eDP-1

and:

xrandr --output HDMI-1 --rotate normal --left-of eDP-1
1
  • Thanks for the info, i'll probably be referring to this answer in the future.
    – dolt
    Apr 4, 2023 at 19:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .