I am running a VMWare Player with a Ubuntu 12.04 LTS Precise Pangolin as Guest on my Windows 7.

Sometimes I get the shutdown blue screen error in Windows, this time it happened when I was running the Player. When I restarted everything Ubuntu gave me the "Login Loop" on adminstrator login.

I log in and there's this black screen where I can only read:

piix4...smbus: Host Smbus controller not enabled . 

When I go to the prompt in root mode it fails to update and only upgraded, specially some plugins ( I think graphic plugins) which also appear in one an error message after quitting the prompt, but they´are successfully installed.

They are not the error message. After that I have been working with the Fail/safe Mode recovery panel.

When I try to update via Root I get errors like this:

W:failed to fetch http://extras.ubuntu.com/ubuntu/dists/precise/release.gpg could not        resolve 'extras/ubuntu.com

There are 8 more like this referring to areas like:

-Us.archive.ubuntu.com - release.gpg

Final Message: some index files failed to download.....they have been ignored or old files are used.

The black screens most of the time pass by too fast for me to pick up any information. But in general I think I have done everything I was able to in the recovery panel including updating network and graphic packages and recovering filesystem packages and the basic stuff ( I am a beginner regarding Linux ) in the root prompt.

Now I am stuck in this screen with graphic options:

- Run in low-graphics mode just for one session
- Reconfigure Graphics
- Troubleshoot the error
- Exit to console login

I am trying to choose to reconfigure graphics but the mouse disappears in the virtual machine screen and sometimes when options change it´s only the first and last option. But this happens from the blue without messages.

This particular option menu is in the regular GUI style against a black screen in Terminal style. Really strange.

  • When you have multiple users, do the other users work? I have two users, the main user loops, the other works perfectly fine. Unfortunately I cannot access my data via the user but I could login as a main user via ctrl+alt+F1. Message for startx: Server is already active for display 0 Delete the locked file "filename" mentioned, then sudo reboot
    – user74866
    Jul 3, 2012 at 22:43

10 Answers 10


I am not sure if what I was experiencing is the same but maybe this will work for you.

I have Ubuntu 12.04 Server LTS updated 6-7-2012 and Desktop installed. I am also running this as a VM in vmware player, not sure if that matters or not.

I had done a ctrl+alt+F1 from desktop to get a shell. When I tried to to start the gui again (sudo startx), I got errors, then after a reboot I got the log-in and when I put in my password it would just loop no error for bad PW! But when I switched to the Guest log-in it would boot normally! What a pain, huh!

So what I did was

  • switch to shell (Ctrl+Alt+F1)
  • logged in as the user
  • cd /home/user (I think that cd ~ will get you to the same place)
  • sudo mv .Xauthority .XauthorityBak
  • sudo reboot

This worked it booted normal and all is good!

There are specifics of my installation which may not apply to yours but maybe it will work.

Hope this helps, K

P.S. I got this info from http://ubuntuforums.org/showthread.php?t=1890457 Thanks carranty

EDIT: I started to get a System Problem Detected when I would log in from a locked desktop so I sudo chown 777 .Xauthority and that seemed to have cleared up the problem. I am not sure if this causes a security issue.

EDIT: Not sure if this did clear up the problem, things are getting funky!

  • anyone think that this might be an issue with the updates? Jun 7, 2012 at 5:05
  • 1
    This did not fix the problem for me.
    – Cerin
    Oct 1, 2014 at 6:34

startx doesn't work

Seems like you lost write-rights... Check whether the solution described here will work for you. This happened to me.

I found a solution for me:

I changed my password, reinstalled xserver-xorg by typing: sudo apt-get install --reinstall xorg

After a reboot it worked for me. Notice: I removed the .XAuthority files in /home/username by: sudo rm /home/username/.XAuthority*

to get a shell try Strg-Alt-F1 when you turn on your computer. I actually got my write-rights back by using clear in recovery mode.


This is the shorter version of Dig's answer, which solved my problem. root had taken ownership over my profile's .Xauthority file. In order to resolve the issue you need to assign ownership over this file back to the user.

sudo chown username:username .Xauthority
  • 1
    How does this happen?
    – Eden
    Nov 29, 2014 at 13:57

Logging in as root at the command shell level and renaming the user's /home/user/.Xauthority and then rebooting seemed to cure the issue. Not sure why it occurred in first place though


These suggested instructions apply to my case only and should be considered as a non-professional comment and therefore to be tried AT YOUR OWN RISK.

I am using ACER Aspire 4755g with Ubuntu 12.04.1 LTS.

I have also encountered this problem, and in my case, I had a problem with lightdm. As a temporary measure, when you get to the login screen, press the keyboard sequence Ctrl+Alt+F1. This will get you to a terminal-like screen. It will show you something like this:


for example,

Aspire-4755g login:

type in your username and press Enter. This will result into something like this,

Aspire-4755g login: shiela


Enter your password, and, if correct, would show something like this:

Aspire-4755g login: shiela


Last login: Tue Jan 1 06:45:02 JPT 2013 on tty1

Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-35-generic-pae i686)

* Documentation: https://help.ubuntu.com/

2 packages can be updated.

0 update are security updates.


Then, press the keyboard sequence Ctrl+Alt+F7 to get you back to the login screen. This procedure logs you into the system using the terminal-like window. You can now try to login to your account using the login screen. In my experience, I was able to reach the desktop. It seems that there is something wrong with the lightdm configuration that it was not able to log you in to the system.

Should you not make it to the desktop (as it was called in Windows), you may try adding an additional command by pressing the Ctrl+Alt+F1:

shiela@Aspire-4755g:~s ecryptfs-mount-private

press Enter, and it will ask you your password. Enter your password, then press the keyboard sequence Ctrl+Alt+F7 to get you back to the login screen (or to where you last left).

This command loads your Home folder, together with its contents, should you have chosen to encrypt the home folder upon installation of Ubuntu.

Once successful, you may try to review your lightdm configuration located on /etc/lightdm/lightdm.conf.


I had same issue, I uninstalled 12.04 version and installed 12.10 Version and the problem is gone.


Yes I caused a Login Loop on my main Ubuntu 12.10 user and the fix was simple.

Background: Ubuntu 12.10 is installed in VirtualBox running on Windows 7 and uses Unity.

Cause: From the Desktop I Ctrl+Alt+T into terminal mode and then tried to run 'startx' (I was trying to help a friend over the phone late at night...but this was a stupid thing to do). A new blank Unity desktop appeared and everything hung...

Problem: Forcing VirtualBox to close and then rebooting Ubuntu I got to the login screen but kept looping back to this same screen everytime after entering the password. No errors were displayed. I could login as Guest but I had no Sudo rights and thus no control... However once logged in as Guest I Ctrl+Alt+F3 and got to a terminal login. I entered my main user name and password and logged in with command mode. Logout took me back to CLI login and Ctrl+Alt+F7 took me back to Guest desktop. So my account still worked. I then added a test user and gave them sudo rights. From the Unity login I could login and logout Test user with no problem. So Unity still worked.

Fix: So my main account was still accessable via CLI and Unity was working for all other accounts. This indicated a configuation problem on my main account. I followed the advice of Ubuntu gets stuck in a login loop and did chown username:username .Xauthority. This fixed my problem.


I had a similar issue. Mine was that I had done sudo -E -s or something at some point. and restarted x, thus root beeing owner of my user's .Xauthority. When I changed ownership back to my normal user, it was golden.


I had the same problem on Ubuntu 13.04. The reason was, that I had some custom entries in the .profile file in my home dir. After removing these entries (as written before: Ctrl+Alt+F1, login, cd ~, edit the file) and a reboot, everything was fine again.

  • 2
    Welcome to Ask Ubuntu! I recommend expanding this answer to explain in greater detail what you did to fix the problem, so that someone reading this answer could follow the steps provided to fix it. Jul 15, 2013 at 8:42
  • As written this does not answer the question but if you expand it to include the details as suggested by Eliah it could be good answer and help others with the same or a similar problem. Jul 15, 2013 at 9:19

I just had a similar problem (the login loops) it even gave me that little drum sound, went black and back to the login screen. Plus I have run into other problems tonight. I have been searching around for the last few hours, with the help of you (the ubuntu community) I picked out a few tips and ideas. I tried logining in as guest (worked but unhelpful.) The list of things I have done tonight to solve this, Renaming that .Xauthority to .Xauth_bak, safe mode terminal to do a disk scan and repair, sudo update this and that. The biggest and most helpful action was--- my Home was 100% full???? from the guest account I CTRL+ALT+F1 and logged in with my regular name and pw, sudo rm .Trash* that made a 2% difference, at that point I was able to ctrl+alt+F7 back to the login screen, I was able to get in!!!! now to clean the 98% issue, I know I dont have that much. <--- hope this helps someone, Thank You Ubuntu Community!!!

Not the answer you're looking for? Browse other questions tagged or ask your own question.