I am trying to connect remotely from an Ubuntu 22.04 desktop to another Ubuntu 22.04 desktop via the internet through VNC on Remmina. The connection works finely, but in order to connect on the connected computer I have to click "accept" which I do not want, because the computer is unattended. How can I enable automatic acceptance?

  • Have you installed and set up a VNC server on the remote desktop or are you using the legacy option of built in Gnome Remote Desktop feature?
    – user68186
    Mar 28 at 11:53
  • I am not aware of a VNC server in particular. I am applying the sharing options in the Ubuntu 22.04 settings.
    – user823
    Mar 29 at 5:43

2 Answers 2


On the remote computer you set the vino-server option for this.

Using dconf-editor go to /org/gnome/desktop/remote-access/ and toggle off the prompt-enabled setting.

Then restart vino-server

  • how do I restart the vino-server?
    – user823
    Mar 29 at 8:08
  • Also, it seems to ignore the prompt-disabling, even after a relog
    – user823
    Mar 29 at 8:16
  • Note, vino is not installed by default in Ubuntu 22.04. VNC desktop sharing is handled by gnome-remote-desktop's legacy toggle in the System Setup app. By default gnome-remote-desktop uses the RDP protocol (without installing xrdp).
    – user68186
    Mar 29 at 16:59

Setup Gnome Remote Desktop with a password

Note: This has nothing to do with the Remmina on the local computer. You have to set it up in the remote computer.

This option is somewhat hidden. Go to the system Setup > Sharing on the left panel >

  1. Turn on Sharing toggle at the right side of the top bar.
  2. Click on the Remote Desktop to open the Remote desktop window.
  3. Make sure the toggle the remote desktop connection is on.
  4. Check the box for Enable legacy VNC Protocol
  5. Click on the three dots next to the Enable legacy VNC Protocol
  6. Click on the radio button Require a Password
  7. Make sure the the Remote Control toggle is on.

See the picture below:

enter image description here

The username and password will be at the bottom of the screen, not shown in the picture. You may change them.

I strongly advice everyone to set the remote access password to something long and random particularly if the remote connection is over the internet. You don't want some hacker to guess and get into your remote computer.

Save the usename and password in Remmina

If you don't want Remmina to ask for the username and password every time you try to connect you may save these within Remmina's Basic Tab. These are what you set in the Remote Desktop settings and can be different from your login username and password.

Hope this helps

  • When I do this, I just get a black screen. But when I use the "New connections must ask for access" it works, though i have to login to the remote using TeamViewer to accept the incoming.
    – Colin
    May 12 at 9:59
  • @Colin Thanks for your comment. I had no problems a few days ago. After I read your comment and I was able to reproduce the problem. The black screen had a square lighter black area in the middle, where the cursor turned into an "x". I toggled the option from "Require a password" to "New connection must ask for access" and I was able to connect as you described. I changed it back to "Require a password" and rebooted the remote computer. After the reboot, I logged in locally to the remote computer. Then remote access using Remmina worked again with password!
    – user68186
    May 12 at 23:19
  • @Colin please ask a new question. I will convert this comment to a full answer. Then you can accept the answer as correct.
    – user68186
    May 12 at 23:41
  • thank you - rebooting the remote worked a treat! The password screen shows up now on the local properly and all is well :-)
    – Colin
    May 13 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.