I'm experiencing a sound issue on a Lenovo P15s laptop having Ubuntu 22.04.2**

There is actually no sound at all; the sound settings displaying a single "DummyOutput" entry:

enter image description here

I went trough several topics, the most relevant being:

without success.

Here are some more information:

inxi output:

$ inxi -SMA

  Host: localhost-ThinkPad Kernel: 5.19.0-35-generic x86_64
    bits: 64 Desktop: GNOME 42.5 Distro: Ubuntu 22.04.2 LTS (Jammy Jellyfish)
  Type: Laptop System: LENOVO product: 20W6004XMZ v: ThinkPad P15s Gen 2i
    serial: <superuser required>
  Mobo: LENOVO model: 20W6004XMZ v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N34ET54W (1.54 )
    date: 11/21/2022
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
    driver: sof-audio-pci-intel-tgl
  Sound Server-1: ALSA v: k5.19.0-35-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes

Current state:

$ cat /proc/asound/cards 

--- no soundcards ---
$ sudo aplay -l

aplay: device_list:274: no soundcards found...

Relevant lspci output:

$ lspci -nnk | grep -A2 Audio

00:1f.3 Audio device [0403]: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller [8086:a0c8] (rev 20)
    Subsystem: Lenovo Tiger Lake-LP Smart Sound Technology Audio Controller [17aa:22c9]
    Kernel driver in use: sof-audio-pci-intel-tgl
    Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl

Some lsmod outputs:

$ lsmod | grep snd_hda_intel

snd_hda_intel          53248  0
snd_intel_dspcfg       36864  2 snd_hda_intel,snd_sof_intel_hda_common
snd_hda_codec         176128  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_core          114688  9 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_sof_intel_hda
snd_pcm               155648  11 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_compress,snd_soc_core,snd_sof_utils,snd_hda_core,snd_pcm_dmaengine
snd                   114688  17 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_sof,snd_timer,snd_compress,thinkpad_acpi,snd_soc_core,snd_pcm,snd_rawmidi
$ lsmod | grep snd_sof_pci_intel_tgl

snd_sof_pci_intel_tgl        16384  0
snd_sof_intel_hda_common    139264  1 snd_sof_pci_intel_tgl
snd_sof_pci                  24576  2 snd_sof_intel_hda_common,snd_sof_pci_intel_tgl
snd_soc_acpi_intel_match     69632  2 snd_sof_intel_hda_common,snd_sof_pci_intel_tgl

Relevant dmesg output:

$ sudo dmesg | grep -e 'audio\|snd\|intel' 

[    1.247027] intel_pstate: Intel P-state driver initializing
[    1.247421] intel_pstate: HWP enabled
[    1.272390] intel_pmc_core INT33A1:00:  initialized
[    4.543674] intel_rapl_common: Found RAPL domain package
[    4.694941] Bluetooth: hci0: Found device firmware: intel/ibt-19-0-4.sfi
[    4.733324] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    4.742861] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    4.801068] intel_tcc_cooling: Programmable TCC Offset detected
[    4.823270] intel_rapl_msr: PL4 support detected.
[    4.824639] intel_rapl_common: Found RAPL domain package
[    4.824641] intel_rapl_common: Found RAPL domain core
[    4.824643] intel_rapl_common: Found RAPL domain uncore
[    4.824644] intel_rapl_common: Found RAPL domain psys
[    4.954922] sof-audio-pci-intel-tgl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    4.956155] sof-audio-pci-intel-tgl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    4.956946] sof-audio-pci-intel-tgl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
[    4.957054] sof-audio-pci-intel-tgl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.963650] sof-audio-pci-intel-tgl 0000:00:1f.3: use msi interrupt mode
[    4.984593] sof-audio-pci-intel-tgl 0000:00:1f.3: hda codecs found, mask 5
[    4.984597] sof-audio-pci-intel-tgl 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    4.984599] sof-audio-pci-intel-tgl 0000:00:1f.3: DMICs detected in NHLT tables: 2
[    4.985395] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:0:0-b678a
[    4.985397] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:20:0 Kernel ABI 3:21:0
[    4.985400] sof-audio-pci-intel-tgl 0000:00:1f.3: unknown sof_ext_man header type 3 size 0x30
[    5.889516] sof-audio-pci-intel-tgl 0000:00:1f.3: cl_dsp_init: timeout with rom_status_reg (0x80000) read
[    5.890171] sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump start ]------------
[    5.890876] sof-audio-pci-intel-tgl 0000:00:1f.3: Boot iteration failed: 3/3
[    5.891678] sof-audio-pci-intel-tgl 0000:00:1f.3: fw_state: SOF_FW_BOOT_IN_PROGRESS (2)
[    5.892332] sof-audio-pci-intel-tgl 0000:00:1f.3: extended rom status:  0x6000021 0x0 0x0 0x0 0x0 0x0 0x25101c2 0x0
[    5.892967] sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump end ]------------
[    5.894076] sof-audio-pci-intel-tgl 0000:00:1f.3: error: dsp init failed after 3 attempts with err: -110
[    5.895372] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to start DSP
[    5.896586] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to boot DSP firmware -110
[    5.947739] sof-audio-pci-intel-tgl 0000:00:1f.3: error: hda_dsp_core_reset_enter: timeout on HDA_DSP_REG_ADSPCS read
[    5.948526] sof-audio-pci-intel-tgl 0000:00:1f.3: error: dsp core reset failed: core_mask 1
[    5.949602] sof-audio-pci-intel-tgl 0000:00:1f.3: error: sof_probe_work failed err: -110
[    6.494346] Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-19-0-4.ddc

** after a firmware upgrade which apparently went wrong because during each reboot it's now written something like

1) "Reading ME Firmware... Please do not power off! 50% Completed"
2) "Recovering ME Firmware...Please do not power off! 10% Completed"
3) "Failed to recover ME Firmware..."

I tried to reinstall the available firmware downloaded from here:

But surprisingly (!), Lenovo is not providing firmwares for Ubuntu 22.04:

enter image description here

And it simply doesn't work:

$ sudo fwupdmgr --allow-older --allow-reinstall install n34rk01w.cab

Decompressing…           [***************************************]
No supported devices found
$ sudo fwupdmgr --version

runtime   org.freedesktop.fwupd         1.7.9
runtime   com.dell.libsmbios            2.4
compile   org.freedesktop.gusb          0.3.10
runtime   org.kernel                    5.19.0-35-generic
compile   com.hughsie.libjcat           0.1.9
compile   org.freedesktop.fwupd         1.7.9
runtime   org.freedesktop.gusb          0.3.10

I am trying to be exhaustive, but I may have missed some crucial information. Don't hesitate to tell me if that's the case.

I simply want my sound card to work again normally.

1 Answer 1


I solved this by running the command suggested here, by github user ruimbribeiro who had a same kind of issue on a Lenovo T14 Gen2i:

$ sudo fwupdmgr reinstall

Choose a device:
0.  Cancel
1.  2292ae5236790b47884e37cf162dcf23bfcd1c60 (Embedded Controller)
2.  349bb341230b1a86e5effe7dfe4337e1590227bd (Intel Management Engine)
3.  04e17fcf7d3de91da49a163ffe4907855c3648be (MZVLB1T0HBLR-000L7)
4.  0d5d05911800242bb1f35287012cdcbd9b381148 (Prometheus)
5.  73e606488fec47b3e3f9288094f66fded0051446 (Prometheus IOTA Config)
6.  a45df35ac0e948ee180fe216a5f703f32dda163f (System Firmware)
7.  362301da643102b9f38477387e2193e57abaa590 (UEFI dbx)
2 <-- picking the second entry
# (...)
# reboot

Then, during the system reboot, I faced the same errors again:

1) "Reading ME Firmware... Please do not power off! 50% Completed"
2) "Recovering ME Firmware...Please do not power off! 10% Completed"
3) "Failed to recover ME Firmware..."

But this is normal, at this stage the system is not aware of the existence of the change I asked in the fwupdmgr reinstall command.

After that it passed by the splashscreen and then the screen stays black for roughly 1-2min.

It finally prints "System Reset" on the top-left.

And it rebooted again. Normally this time.

Everything is working fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.