I have a problem with my network connection. I have been using the same laptop with Ubuntu and the same connection for more than a year, and suddenly yesterday the connection stopped working (both wireless and wired). I've tested with another computer and the connection is fine (both wireless and wired).

I've been reading similar posts but I haven't found a solution yet. I tried a few commands that I'm posting here (my system is in spanish, so I have traslated it to english, maybe the terms are not accurate):

grep -i eth /var/log/syslog | tail

Jun  3 18:45:40 vanesa-pc NetworkManager[3584]: <info> (eth0): now managed
Jun  3 18:45:40 vanesa-pc NetworkManager[3584]: <info> (eth0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jun  3 18:45:40 vanesa-pc NetworkManager[3584]: <info> (eth0): bringing up device.
Jun  3 18:45:40 vanesa-pc NetworkManager[3584]: <info> (eth0): preparing device.
Jun  3 18:45:40 vanesa-pc kernel: [ 7351.845743] forcedeth 0000:00:0a.0: irq 41 for MSI/MSI-X
Jun  3 18:45:40 vanesa-pc kernel: [ 7351.845984] forcedeth 0000:00:0a.0: eth0: no link during initialization
Jun  3 18:45:40 vanesa-pc kernel: [ 7351.847103] ADDRCONF(NETDEV_UP): eth0: link is not ready
Jun  3 18:45:40 vanesa-pc NetworkManager[3584]: <info> (eth0): deactivating device (reason 'managed') [2]
Jun  3 18:45:40 vanesa-pc NetworkManager[3584]: <info> Added default wired connection 'Wired connection 1' for /sys/devices/pci0000:00/0000:00:0a.0/net/eth0
Jun  3 18:45:40 vanesa-pc kernel: [ 7351.848817] ADDRCONF(NETDEV_UP): eth0: link is not ready

ifconfig -a

eth0      Link encap:Ethernet  addressHW 00:1b:24:fc:a8:d1  
          ACTIVE BROADCAST MULTICAST  MTU:1500  Metric:1
          Packages RX:0 errors:16 lost:0 overruns:0 frame:16
          Packages TX:123 errors:0 lost:0 overruns:0 carrier:0
          colissions:0 length.tailTX:1000 
          Bytes RX:0 (0.0 B)  TX bytes:26335 (26.3 KB)
          Interruption:41 Base address: 0x2000 

lo        Link encap:Local loop  
          Inet address:  Mask:
          Inet6 address: ::1/128 Scope:Host
          ACTIVE LOOP WORKING  MTU:16436  Metrics:1
          Packages RX:1550 errors:0 lost:0 overruns:0 frame:0
          Packages TX:1550 errors:0 lost:0 overruns:0 carrier:0
          colissions:0 long.tailTX:0 
          Bytes RX:125312 (125.3 KB)  TX bytes:125312 (125.3 KB)


lo        no wireless extensions.

eth0      no wireless extensions.

sudo lshw -C network

       description: Ethernet interface
       product: MCP67 Ethernet
       manufacturer: NVIDIA Corporation
       Physical id: a
       bus information: pci@0000:00:0a.0
       logical name: eth0
       version: a2
       series: 00:1b:24:fc:a8:d1
       capacity: 100Mbit/s
       width: 32 bits
       clock: 66MHz
       capacities: pm msi ht bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.64 latency=0 link=no maxlatency=20 mingnt=1 multicast=yes port=MII
       resources: irq:41 memoria:f6288000-f6288fff ioport:30f8(size=8) memoria:f6289c00-f6289cff memoria:f6289800-f628980f


Module                  Size  Used by
usbhid                 41906  0 
hid                    77367  1 usbhid
rfcomm                 38139  0 
parport_pc             32114  0 
ppdev                  12849  0 
bnep                   17830  2 
bluetooth             158438  10 rfcomm,bnep
binfmt_misc            17292  1 
joydev                 17393  0 
hp_wmi                 13652  0 
sparse_keymap          13658  1 hp_wmi
nouveau               708198  3 
ttm                    65344  1 nouveau
drm_kms_helper         45466  1 nouveau
drm                   197692  5 nouveau,ttm,drm_kms_helper
i2c_algo_bit           13199  1 nouveau
psmouse                87213  0 
mxm_wmi                12859  1 nouveau
serio_raw              13027  0 
k8temp                 12905  0 
i2c_nforce2            12906  0 
wmi                    18744  2 hp_wmi,mxm_wmi
video                  19068  1 nouveau
mac_hid                13077  0 
lp                     17455  0 
parport                40930  3 parport_pc,ppdev,lp
forcedeth              58096  0

Let me know if I can give you more information.

  • I have the same problem, I think it could be a update...
    – Delta
    Jun 6 '12 at 3:03
  • My WiFi went offline suddenly. <br>The syslog also contained a message like: <info> (eth0): deactivating device (reason 'managed') [2] I discovered the WiFi had been disabled because I'd accidentally hit the WiFi toggle button.
    – user88242
    Oct 25 '12 at 5:10

Managed to get mine going just now after upgrade to Ubuntu 12:

Edited /etc/network/interfaces:

The line #iface eth0 inet dhcp was commented out; I removed the "#".

Then I ran sudo ifup -a, and it brought up the network.

Sorry about the network manager, folks, but if there's one piece of software that should be 110% ready before a release, that would be it.


I had a similar problem which was caused by a network-manager package update. I could solve it as follows:

  1. Download the previous version of the network-manager packet on a different computer from this page (scroll down and click on your cpu architecture).

  2. Copy the file to your computer and install the package via sudo dpkg -i packagename.

  3. Reboot.

  4. If this solves the network problem you can start synaptic, search for the network-manager packet, select it, go to "Package" in the menu and then click "lock version". Otherwise Ubuntu will try and update the package again.

  • Hello Karl, thanks for your help. Sadly it doesnt work. It tried with this version, and also with the previous one. Finally I reinstalled the latest version just in case.
    – Jonathan
    Jun 8 '12 at 0:59
  • Ah, before I tried that, this morning when I turn the pc on, strangely the connection worked. Then I rebooted it to be sure, and then it was missing again. While it was working I was able to get the model of the wireless card with the lspci -k command: 03:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01) Subsystem: Hewlett-Packard Company Device 137b Kernel driver in use: ath5k Kernel modules: ath5k
    – Jonathan
    Jun 8 '12 at 1:02

I had a similar problem: I have two laptops running 12.04 and one was suddenly unable to connect to the Internet.

I recursively copied the directories /etc/network/ and /etc/NetworkManager/ from the working laptop to the other one via USB stick and restarted. I was still unable to connect with wired LAN, so I switched that off, turned on wireless and the connection worked. I switched back to wired and that was working too.

Not the most elegant solution, and it requires access to a working Ubuntu machine, but it worked for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.