After a reinstall of Ubuntu 12.04 ,it's impossible to install commercial games, e.g Oil Rush. It gives this error:

Failed to fetch https://private-ppa.launchpad.net/commercial-ppa-uploaders/oilrush/ubuntu/dists/oneiric/main/binary-amd64/Packages  The requested URL returned error: 401
Failed to fetch https://private-ppa.launchpad.net/commercial-ppa-uploaders/oilrush/ubuntu/dists/oneiric/main/binary-i386/Packages  The requested URL returned error: 401
Some index files failed to download. They have been ignored, or old ones used instead.

I bought these games in 11.10, but I installed these games in 12.04 before... How can I solve this problem?

  • 1
    have you tried the "reinstall previous purchases" from the File menu in the Software Centre? – amc Jun 3 '12 at 19:27

I had the same problem trying to reinstall Steel Storm: Burning Retribution.

Error 401 is an authentication error.

I just found out to get it back for my case I hope it will help.

First, you need to know that your authentication details for the PPA are stored in /etc/apt/auth.conf.

Second you need to verify that the details are correct by going to https://launchpad.net and connecting with the details you used to purchase the software.

Once logged in click on your name if the right top corner (next to the logout button).

In the "Personal package archives" section click on "View your private PPA subscriptions".

On the right side of the line corresponding to your purchase click on "view"

You should now see something that looks like this:

deb https://USERNAME:PASSWORD@private-ppa.launchpad.net/commercial-ppa-uploaders/PURCHASE/ubuntu YOUR_UBUNTU_VERSION_HERE main

Verify that USERNAME and PASSWORD respectively match login and password in your /etc/apt/auth.conf file.

Once /etc/apt/auth.conf is updated with the correct details, run as sudo apt-get update from the terminal and check if you still get error messages, if you don't you should now be able to re-install the game.

Another problem that you can have is if your game doesn't have a PRECISE version yet, in that case you need to go in /etc/apt/sources.list.d/ and modify the file containing the description of the private PPA (in my case /etc/apt/sources.list.d/private-ppa.launchpad.net_commercial-ppa-uploaders_steel-storm2_ubuntu.list).

Example in my case:

I had to replace this line:

deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/steel-storm2/ubuntu precise main

...with this:

deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/steel-storm2/ubuntu oneiric main
  • After editing the auth.conf file installing this software works again! Many thanks for the clear description how to solve this :) – kebabfish Jun 11 '12 at 15:11

There might be a Temporary sever down , so do as open Update Manager and click at Settings then it will open a window and in that window at the Ubuntu Software TAB you have an option to change the server . so there change the server to Main server or Best server to your location and try again .

  • I tried different servers, but I still have this problem. I did change my username and password of my account, but a untill a few weeks ago this was not a problem... – kebabfish Jun 3 '12 at 19:18
  • i think you need to give a user ID and password to allow your Ubuntu machine for Private PPA's . – rɑːdʒɑ Jun 3 '12 at 19:25
  • How can I do that? I already tried to change my account back with the original username and password, but that didn't solve the problem. – kebabfish Jun 5 '12 at 12:27
  • consult the maintainer of them , that would help you . – rɑːdʒɑ Jun 5 '12 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.