I updated a Ubuntu server (HP ProLiant DL325 Gen10) that was still running eoan using do-release-upgrade. The updates seemed to have been installed without any errors. After the update, I tried to reboot the server. However, during boot (without any error messages), the server only gets to the prompt for the password for the disk encryption (luks). After entering the password, nothing happens. The boot process simply does not continue. The server is not frozen, though. If I type something on the keyboard, it is displayed, or if I connect USB devices, corresponding messages are displayed.

What I have tried so far:

  • using another kernel version
  • using a live system and chroot to
    • update the initramfs
    • update grub
    • do another do-release-upgrade to Jammy

But so far, nothing has helped.

Edit: Actually there is an error message immediately before the password prompt: Volume group <name of the volume group inside the luks container> not found.

New contributor
johnbaum is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Did you check /etc/fstab and can you manually mount the mentioned volume from the live system? When I upgraded from 18.04 to 20.04 I had a file with 0 bytes in /boot (don't remember which one), after fixing this it booted again.
    – Umbertones
    2 days ago
  • @Umbertones: /etc/fstab looks fine and mounting the volumes from the live system works flawlessly. There are no empty files in /boot.
    – johnbaum


Your Answer

johnbaum is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.