I have a dual boot setup with Windows 10 and Ubuntu 22.04 LTS. Now there is a issue with my Ubuntu partition not being able to connect to my router, but interestingly, i can connect to the WiFi router from the Windows partition and other devices such as an Android phone.

Previously, the Ubuntu partition was also able to connect to the WiFi router without any issues. However, after i booted into Windows (to use a windows software), and then booted back into Ubuntu, the ubuntu partition is not able to connect to the WiFi router again.

When i'm booted into Ubuntu and try to connect to my WiFi, the connection is being timedout, and noting happens. I've also tried changing configuration to be the same as my other devices, but it doesnt make a difference.

I've tried diagnosing the issue, but It's challenging by the fact that tools such as ifconfig, ifdown and network-manager is not installed on the Ubuntu partition either. However I've tried using WireShark to capture and inspect network packages, but there is no packets being sent from my computer whenever i try to connect to the router.

Here is some of things i've already tried:

  • Disabling firewall
  • Disabling ipv6
  • Disable fast startup (in windows power settings)
  • Use static IP and set manually configuration to WiFi
  • Adding route https://www.poftut.com/add-new-route-ubuntu-linux/ (followed this guide)
  • Changing band selection from automatic to force 2.4GHz

Additional information about wireless info: https://paste.ubuntu.com/p/nFz7GpCn9d/

New contributor
DG_88 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.


Your Answer

DG_88 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy