2

I am trying to upgrade to next LTS version. When I run sudo do-release-upgrade facing below error. Did not get much help from google. Any help will be much appreciated?


You are using pam_tally or pam_tally2 in your configuration. 

The pam_tally and pam_tally2 modules have been removed from PAM. You 
are using one of these modules in your PAM configuration in 
/etc/pam.d. You must remove the uses of these modules before PAM can 
be upgraded; including these modules in your PAM configuration after 
the upgrade will stop users from being able to log into the system. 

Consider the pam_faillock module as a replacement for pam_tally. 


Restoring original system state

Aborting
Reading package lists... Done    
Building dependency tree          
Reading state information... Done
=== Command detached from window (Mon Mar  6 18:59:02 2023) ===
=== Command terminated with exit status 1 (Mon Mar  6 18:59:12 2023) ===
2
  • I'm not aware of any tool that will do this migration for you automagically - you will need to manually remove uses of pam_tally / pam_tally2 from the files in /etc/pam.d and then (if you wish) set up pam_faillock - see for example How do I set up pam_faillock? Commented Mar 7, 2023 at 13:12
  • Thanks, It worked after removing unwanted entires. Commented Mar 28, 2023 at 2:42

1 Answer 1

3

Thank you guys, we were having trouble with updating the Openmedia (pam_tally, pam_tall2), removed the items found in /etc/pam.d (egrep -i pam_tally *).

I was able to upgrade the files and used the maintainer version.

I will continue to test but it is looking good.

Again, thank you.

Todd

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .