5

Running Ubuntu 22.04.2, since the kernel 5.19.0-35, there is an issue with the HDMI audio output. Can you help me to retrieve my HDMI audio output please?

enter image description here enter image description here

With kernel 5.19.0-32, HDMI output is found:

$ uname -a
    xxx 5.19.0-32-generic #33~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Mon Jan 30 17:03:34 UTC 2 x86_64 x86_64 x86_64 GNU/Linux
    cat /proc/asound/cards
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0xa0340000 irq 127
     1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                          HDA ATI HDMI at 0xa01a0000 irq 128

With kernel 5.19.0-35, HDMI output is not found:

$ uname -a
    xxx 5.19.0-35-generic #36~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Feb 17 15:17:25 UTC 2 x86_64 x86_64 x86_64 GNU/Linux
    $ cat /proc/asound/cards
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0xa0340000 irq 127

$ inxi -Fam
Audio:
          Device-1: Intel Comet Lake PCH-V cAVS vendor: Micro-Star MSI
            driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_cnl
            bus-ID: 00:1f.3 chip-ID: 8086:a3f0 class-ID: 0403
          Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
            gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab38
            class-ID: 0403
          Sound Server-1: ALSA v: k5.19.0-35-generic running: yes
          Sound Server-2: PulseAudio v: 15.99.1 running: yes
          Sound Server-3: PipeWire v: 0.3.48 running: yes
        
$ aplay -l
**** Liste des périphériques matériels PLAYBACK ****
carte 0 : PCH [HDA Intel PCH], périphérique 0 : ALC897 Analog [ALC897 Analog]
Sous-périphériques : 1/1
Sous-périphérique #0 : subdevice #0
        
$ lspci | grep -i audio
00:1f.3 Audio device: Intel Corporation Comet Lake PCH-V cAVS
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 HDMI Audio
2
  • Had the same issue, downgrading the kernel fixed it for me as well, but I needed to do it the hard way since it was a fresh install on a new system. I downgraded to 5.15.104. askubuntu.com/a/1420274/549798
    – tlhIngan
    Commented Mar 23, 2023 at 18:29
  • I experienced the same issue with kernel 5.19.0-35 on my hardware Gigabyte model: F2A68HM-H. As of April 14th 2023 HDMI sound is working fine with Linux Mint 21.1 Cinnamon. It's currently using Kernel: 5.15.0-69.
    – user847062
    Commented Apr 14, 2023 at 21:13

1 Answer 1

2

Simply, I removed the kernel concerned and back to the previous kernel.

sudo apt --purge remove linux-headers-5.19.0-35 linux-headers-5.19.0-35-generic linux-image-5.19.0-35-generic linux-modules-5.19.0-35-generic

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .