1

I'm trying to do a clean install of Ubuntu Server 22.04 into a host that has 2 NVIDIA A6000 GPUs. My goal is to install the NVIDIA proprietary drivers and CUDA.

However, while the clean installation works fine, the moment I install the official NVIDIA drivers or disable the Nouveau driver it freezes on boot just before the point where it would normally change the screen resolution as it boots up, still showing more text. (This is not Ubuntu Desktop, so there's no UI starting, just a console login.)

To be more specific:

  • Nouveau enabled, no NVIDIA driver: works
  • Nouveau disabled, no NVIDIA driver: freezes
  • Nouveau enabled, NVIDIA driver: freezes
  • Nouveau disabled, NVIDIA driver: freezes

I've also tried using different versions of the NVIDIA server driver (525, 515...) as well as the official sh installer with no change. Secure boot is also disabled from the BIOS.

Also, when I manually install the NVIDIA proprietary driver and before rebooting, I can see my GPUs correctly using nvidia-smi. Yet the moment I reboot it freezes always in the same point. Doesn't matter how much I wait for it to continue. Checking the system journal didn't seem to give any useful clues either.

Any suggestions about what else I could try?

2
  • Are you sure the computer "freezes"? If you are at the console what happens when you hit Ctrl-Alt-F1? When you install graphics drivers and do not install graphical applications the system will boot into graphical.target and the console will show a blank black screen. Commented Mar 5, 2023 at 2:17
  • The system does not respond to Ctrl-Alt-F1 (or any other F keys). Furthermore, the server has an openssh server installed, and no matter how long you wait it doesn't respond either. Or even to pings. Commented Mar 5, 2023 at 7:39

1 Answer 1

1

Found a way to avoid the freezes by adding nomodeset to grub.

How do I set 'nomodeset' after I've already installed Ubuntu?

1
  • This worked for me. I booted into recovery mode (under "Advanced Options for Ubuntu", navigated to /etc/default and edited the grub config options with nano grub. Added nomodeset so that "quiet splash" becomes "quiet splash nomodeset" Commented Mar 27, 2023 at 16:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .