i am unable to set up my canon lbp2900 printer on ubuntu12.04 64 bit i aliened the 64 bit rpm drivers and then installed the drivers (version 2.40) and followed the procedure in the canon guide ( however i changed fifo path to //localhost:59787 (somebody suggested) instead of 59687 (as suggested by canon guide) )

intially i got the message pstocapt failed .. the drivers had put the pstocapt and backend/ccp in the lib64 directory instead of the lib directory ... i copied that to the aproprite directory under lib

but still i get the error "ccp send_data error exit " i also tried with fifo path //localhost:59687

i also tried the Radu script but the drivers the script uses are version 1.90 and has conflicting packages


For 12.04

Don't worry, for printing you have to enter the following everytime after fresh boot:

sudo modprobe usblp
ls -l /dev/usb/lp0
sudo ccpd start

It works for me with the 32-bit driver installed according to the community documentation.

  • Please link the community docs, and cite the relevant sections. It is for the good of this site, and the Internet. – Captain Giraffe Jun 21 '12 at 16:04
  • 1
    (1) You may want to explain how to make this run automatically on boot (with /etc/rc.local, or otherwise). (2) The ls command does not change anything--it just shows some information about the lp0 device entry. So why should the ls command be run each time? – Eliah Kagan Jun 22 '12 at 13:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.