I have downloaded Bastion for Ubuntu and installed in the home folder normally.

When executing "Games > Bastion" nothing happens. Running Bastion directly from the installation folder results in the error below

Unhandled Exception: System.EntryPointNotFoundException: glProgramParameteri
  at (wrapper managed-to-native) OpenTK.Graphics.OpenGL.GL/Core:ProgramParameteri (uint,OpenTK.Graphics.OpenGL.AssemblyProgramParameterArb,int)
  at OpenTK.Graphics.OpenGL.GL.ProgramParameter (Int32 program, AssemblyProgramParameterArb pname, Int32 value) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.EffectPass.ApplyPass () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.Effect.DefineTechnique (System.String techniqueName, System.String passName, Int32 vertexIndex, Int32 fragmentIndex) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteEffect..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteBatch..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at GSGE.ExceptionGame.LoadContent () [0x00000] in <filename unknown>:0 

I have tried some solutions on the internet, like adding OpenTK.dll.config the line below:

<dllmap os="linux" dll="libXi" target="libXi.so.6"/>

This didn't help. Also tried running as sudo and that didn't help. Some posts said that this might be a problem with Ubuntu noveau drivers. But I'm using the NVIDIA proprietary drivers.


OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 9400 GT/PCI/SSE2
OpenGL version string: 3.2.0 NVIDIA 195.36.24
direct rendering: Yes
  • <dllmap os="linux" dll="libXi" target="libXi.so.6"/> this is for mouse problems not for your problem! – Ashu Jun 3 '12 at 4:12
  • I was desperate – user68008 Jun 3 '12 at 4:17
  • I have the exact same problem in Fedora 16 and with intel gm965, so, its not the OS or a Nvidia specific problem. – user68021 Jun 3 '12 at 5:37
  • That is a good information – user68008 Jun 3 '12 at 22:04

I was receiving the same error with the version Bastion-HIB-2012-05-29-1.sh released in the humble bundle, without delving deeper it seems to me that on some configurations the static links are incorrect.
There is a new build available, Bastion-HIB-2012-06-01-1.sh which resolved the problem for me.

My system is also Ubuntu 10.4 running the nVidia drivers

  • You are correct, this solved it. I played the game for quite a while, pretty good. (As a side note, after 3-4 hours playing my computer overheated and somehow is not working anymore I don't blame the game, the computer was quite bad even before this) – user68008 Jun 6 '12 at 15:53
  • lucky you. I am still having the problem with the build from 2012-06-20 – santiagozky Jun 21 '12 at 18:33

<dllmap os="linux" dll="libXi" target="libXi.so.6"/>

That is for mouse problems not for your problem! - thanks a lot, that fixed my mouse problem in Bastion! Combined withforce_s3tc_enable=true, /usr/local/games/Bastion/Bastion.bin.x86_64 it is quite playable now (just need to take care of that rain further in the game).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.