I have ubuntu 12.04 64bit using Google Chrome. I had chromium from the app center then today amazon prime video stopped working. It told me to update Flash. So I uninstalled chromium and installed Google Chrome. Didn't work. Then I downloaded flash for ubuntu via apt. That one gave me a "flash version isn't supported" message. The flash version was 11.

Now I tried http://apt.ubuntu.com/p/flashplugin-installer

It worked, but right in the middle of the video, it popped the error message again.

Sorry we are unable to stream this video. This is likely because your Flash Player needs to be updated.

So I don't know what happened.

  • The solution from jpetersen works, you should mark that as the correct answer if you still can - i did it with chromium and it is playing Amazon Instant wonderfully on Ubuntu 12.04
    – schmoopy
    Jul 15, 2013 at 22:27

10 Answers 10


I had this same problem on Ubuntu 12.04 using Chromium. I fixed it my following the instructions on the adobe help page for installing Hardware Abstraction Layer module:

Prerequisites for protected content playback

For Ubuntu 10.04 or later, ensure that the Hardware Abstraction Layer module is first installed using apt-get. (Watch carefully for “hal” install errors, as a damaged package install can continue to affect video playback.)

sudo apt-get install hal

After the "libhal" (HAL) library install completes, close the browser and clear the Adobe Access directories by executing the following shell commands:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Note: If the Hardware Abstraction Layer module is missing, Flash Player still functions. However, it cannot play protected content that requires the Adobe Flash Access DRM (Digital Rights Management) module.

  • This was exactly what I needed to get Flash playing correctly on Chromium. I was able to play most Flash videos in Firefox, and when Googling for the answer, many people blame it on Flash version or Flash installation.
    – earthmeLon
    Jul 2, 2014 at 19:29

This is probably not working in Google Chrome for Linux because of the limitations of the Pepper Flash as Google mentions on their support page:

Linux users: Adobe Flash Player uses a cross-platform API, Pepper API (PPAPI), to run its plug-in in Chrome. You might notice some of the known issues below specific to Linux Chrome:


  • Viewing Adobe Access (DRM) content is not supported, since Adobe does not support it on Linux.


I think it's very much likely that:

  • Support for the older 11.2 Flash for Linux (using the regular API) has been dropped by Amazon.
  • Support for the DRM required in 11.7 in Chrome for Linux does not work because of the aforementioned limitations of it.

This makes Ubuntu fall between two stools in the support for watching DRM-enabled video.


try opening this page. You will see a small box with the title version information. Furthermore, it will run a short flash video as a test and tell you

1) if your flash plugin does function properly

2) the exact version of flash you have installed (good basis for further troubleshooting)

Even though it is no solution directly, it might be helpful for you.

  • 1
    That did tell me! the version for linux chrome is up to date. but is older than Windows and Mac. so i guess i will just have to wait till Adobe releases an update for linux.
    – Alex
    Jun 11, 2012 at 18:59
  • 1
    @Alex did you try to install HAL? I got that exact same message to go away by installing it, and am now able to watch Amazon Prime videos.
    – jpetersen
    Jun 16, 2012 at 7:14
  • By using Chrome Browser (NOT CHROMIUM) you are always provided with the most current version of Flash available on Linux.
    – MrMuretto
    Jul 2, 2013 at 0:22
  • @MrMuretto The version of Flash bundled with Chrome does not play protected content such as Prime videos. Jul 9, 2013 at 2:10
  • @jimirings Ah ok, good to know... I did not know that.
    – MrMuretto
    Jul 10, 2013 at 23:21

On my 10.04 system, I ran Synaptic Package Manager, searched for flash and found a package called flashplugin-installer version Picking it for installation caused it to remove the earlier version of flash plugin that was for 64bit. However, this solved the issue for me. I can now play prime instant videos.


Sometimes when flash gets automatically updated, the newer version doesn't work for me like my previous one had. I couldn't find an easy way to downgrade, but here is one way that works for me when I use firefox:

  1. Download the previous working version of adobe from the flash player archives. From what I can tell, the 11.2.202.xxx versions are for Linux. The version I downloaded,, came in a compressed folder. When I extracted it, I saw that libflashplayer.so was inside.
  2. I moved libflashplayer.so into ~/.mozilla/plugins/.
  3. Restart firefox. Watch your videos.

Another common problem with Flash, especially in 12.04, is "Gnash" that little bugger caused me numerous problems with flash. Just completely remove Gnash, and then download the flash plug-in from Adobe or the "Software centre".

The terminal way:

sudo apt-get autoremove --purge gnash && sudo apt-get install adobe-flashplugin -y

For those whom don't know, removes Gnash and the configurations (with purge) then installs the latest version of flash. You may need to reboot afterwards (something I don't do very often if i'm honest).

Edit You may need to reboot once Gnash is removed, sometimes it's configurations are active in the current session.

  • the install part of the command doesnt work. says adobe-flashplugin has no install candidate.
    – Alex
    Jun 15, 2012 at 21:59
  • Go to Adobe directly (get.adobe.com/flashplayer) they've possibly changed the repository. Although you can sudo apt-get update to update the repository, and sudo apt-cache search <search_phrase> to find a certain item in the repositories.
    – Ash
    Jun 17, 2012 at 17:00

Chrome has Flash support built into the browser. This is not like how Firefox uses flashplugin-installer/flashplugin-nonfree or adobe-flashplugin (which are separate from the browser, but utilized by the browser). The Ubunbu packaged plugin can use the HAL, whereas the built in plugin to chrome cannot.


/.adobe/Flash_Player/* probably doesn't have the right permissions even if you re-install. Try the following if you're stuck after all of the above:

sudo apt-get purge flashplugin-installer ubuntu-restricted-extras
sudo apt-get install flashplugin-installer ubuntu-restricted-extras

Close Chromium and:

cd ~/.adobe/Flash_Player
rm -rf ./*

Open Chromium and try to play the troublesome video (it probably will not play yet) and then:

cd ~/.adobe/Flash_Player
chmod 777 *

Chances are that these last two commands are all you really need to do. The rest is only there for completeness.


I am an Ubuntu newbie and tried various work arounds to do with flash not being installed, or not having an up to date version of chrome or chromium etc to get amazon music to work in Chrome and Chromium. In the end went to firefox and went to add ons> plug ins> ... set shockwave flash to always activate and now its running fine.


Go to your Google chrome Add-on and search for adobe flash for Google chrome and install the right one for your browser. I think it has something to do with your browser. Have you tried it in other browser like Firefox?

  • Its the same in Firefox
    – Alex
    Jun 12, 2012 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .