I moved my Ubuntu 12.04 install over to an SSD drive. Copied all directories except for the ones most often written to - var, tmp, ...

Reinstalled grub into SSD by booting with live CD and following the commands in this post: How to move Ubuntu to an SSD

This seemed to work fine, because when I press "e" in grub menu, I see the expected UUIDs.

But right after grub I get could not log bootup: Address already in use the disk drive for / is not ready yet or not present.

If I skip, I get same for /tmp /run, and other dirs

If I go into manual recovery and do

mount -n -o remount,rw /

it turns out that everything can mount no problem.

Can't get my head around this one. My fstab seems right. grub is right. AHCI in bios is enabled. Why is this happening? What can I do to fix it? When I do drop into shell from this error and get to mount things manually, how do I get the OS to continue loading?

Thank you guys for any ideas you can give me.

Here's what my fstab looks like right now:

# <file system>                           <mount point>   <type>      <options>             <dump>  <pass>
proc                                      /proc           proc        defaults              0       0
UUID=67fc8a7a-f1db-485c-88bd-e007c214244f   /               ext4    defaults,noatime,discard  0       1
# swap was on /dev/sda3 during installation
UUID=6bc9cd6c-46b7-43a0-bfac-bd04cc26cfb6   none            swap        sw                    0       0
UUID=7397729b-2125-4b1d-b5eb-28866898d773   /hdd            ext4    errors=remount-ro         0       1
/hdd/home                                   /home           none    bind                      0       0
/hdd/run                                    /run            none    bind                      0       0
/hdd/var                                    /var            none    bind                      0       0
tmpfs                                       /tmp            tmpfs   rw,nodev,nosuid,exec,mode=1777,size=1024m 0     0
/dev/scd0                                   /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

output from blkid:

/dev/sda1: LABEL="System Reserved" UUID="EABC56C1BC568849" TYPE="ntfs" 
/dev/sda2: UUID="7CCC6124CC60D9C2" TYPE="ntfs" 
/dev/sda3: UUID="6bc9cd6c-46b7-43a0-bfac-bd04cc26cfb6" TYPE="swap" 
/dev/sda5: UUID="7397729b-2125-4b1d-b5eb-28866898d773" TYPE="ext4" 
/dev/sdb1: UUID="67fc8a7a-f1db-485c-88bd-e007c214244f" TYPE="ext4" 

relevant from fdisk -l:

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048   115345407    57671680   83  Linux

1 Answer 1


The problem resolved mysteriously. I learned that pressing Esc when the "Skip / Manual Recovery" message comes up, you get to see the last error in the system. Mine was problem with some rule hrdjconsole.rule under rules.d. I tried to apt-get remove package libdjconsole associated with it, but got an error. But on next reboot somehow everything "just worked" all the way up to the KDE gui. I reinstalled the grub just in case, found the right name for that libdjconsole0 in synaptic, purged it and had no problems ever since. Why did I not have this issue when booting from normal hard drive previously and just getting it now - and whether this actually was the issue - I don't know.

Before trying to remove the problem package while in recovery console, I also went through mounting all items from fstab manually one by one. Maybe it has instilled confidence into mountall and it decided to do it by itself the next time :)

I hope that this post is not entirely useless.

PS: the increase in performance is really awesome. SSD breathed life into my old machine. Boot time went from 2 minutes (from grub prompt to KDE desktop - 1.8G Core2Duo, 4GB RAM) to 40 sec. Anything that requires reading a lot of small files - e.g. Synaptic building it's database - is now almost instant. Pretty awesome!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .