I downloaded the 10.04.4-dvd-amd64.iso file, then burned it to a DVD. I then tried installing it but it hangs at 95%. I then checked the hash with md5sum and they are not the same. The ISO is the same as listed on ubuntu.com.

I burned the ISO using Brasero.

These are the hashes:

ubuntu-10.04.4-dvd-amd64.iso 4083424d0f0030e5480f2d183225616d
/dev/dvd1 06631e0997be558620f613a0658331d9

4 Answers 4


Please burn it again, this time setting the lowest possible speed (in Properties) and also turn the image checksum option on, if it isn't.

  • the lowered speed worked.
    – Alex
    Jun 3, 2012 at 2:17

Note: These apply only if you are trying to burn your DVD in Windows

For example: Go to "Device Manager" > YOUR BURNER DRIVE > "Properties" > "Details" Tab > "Property" dropdown > "Driver Key"

See what it says, probably says the same thing as in your post.

Because the latter is associated with your DVD burner (e.g. go into devce manager and property of device and look at the device ID, etc.). The device simply used its own language to write the disc while the first one was from another median or computer all together.

Sorry for the confusion in earlier posting.

First download the Nullriver WinMD5Sum Software (install on Windows; there are other versions available also for Linux and Mac).

  • Open program and select the Ubuntu image file and click open

  • Click the "Calculate" button

  • Go to this link and find the MD5 Hash associated with your image file version.

  • Copy the hash (only) from website

  • Paste the hash from website into the Nullriver software and click calculate.

The resulting information will tell you if the image you have is valid or if it's corrupted. If it's corrupted find a new location to download from or select a different version to image all together.

  • I thought he was in Windows trying to create a bootable media device for using Ubuntu. I can't find the post remove option, any ideas?
    – PCSpartan
    Jun 8, 2012 at 19:48
  • OP said /dev/dvd1, which is not Windows syntax
    – ish
    Jun 8, 2012 at 20:04

You can also get this error on a correctly written CD or DVD as the burning process can add a few sectors to the end of the burn. That's OK as they are never read in while using the CD.

If you have verified the checksum of the ISO you have written you can start a terminal session with Alt-Ctl-T and enter:

ls -ltr *.iso

and determine the length of the iso in bytes. Then enter:


and then (subsituting the name of the iso and the name of your optical device):

cmp quantal-desktop-i386.iso /dev/sr0 -n $length

If there is no message the files are equal.

or as an alternative:

dd if=/dev/sr0 bs=512 count=$(($length/512)) | md5sum

and check the checksum against the Ubuntu web site as you did with the .iso file.

If the checksum of the downloaded .iso file matched the Ubuntu web site, and if Ubuntu produced a valid checksum as it was burning the CD or DVD, it isn't necessary to worry about any of this.


I've been looking for a burning program that gives the option of not using padding for a while.

Not sure if xcdroaster used to, k3b did, not sure if it does now. You could try it. I can't use it anyway as I don't want polkit to have permissions on my systems and k3b via udisks can't find the devices without it, it's so clever it can't even look at device files when told.

I even tried mounting an iso on /dev/loop for a copy but again the 'modern' or perhaps should be called inexperienced GUI programs wouldn't accept the device FILE and xfburn doesn't have a copy otherwise it would probably work.

I was thinking of getting the old k3b version but the underlying programs have changed so much I'm not sure it would work.

The commandline tool xorriso didn't seem to like nopadding with the cdrecord option but cdrskin worked.

cdrskin -v dev=/dev/sr0 blank=as_needed -nopad speed=12 file.iso

It's so much better being able to verify the security and integrity in one go!

The caveat is the cd may not work with all devices as the padding is default for data to get around some driver bugs apparently. Never happened to me though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .