7

Some months now, it's taking very long to logout/shutdown/reboot my ubuntu box.

  • it doesn't happen with a fresh profile
  • it still takes ages even when i close all running programs first (foreground programs)
  • sometimes a couple of applications are closed before the waiting time (eg. chrome, music player)
  • it happened with 11.10 and now 12.04
  • i did a fresh install of 12.04 but reinstalled all my programs and application settings/profiles (eg. chrome profile, music db, .bashrc etc.), still no solution
  • it happens only when i use the gnome way of rebooting/shutting down/logging out
  • when issuing "sudo reboot" in the terminal, there is no waiting time
  • there is no process eating CPU time
  • i have not found any evidence what is causing this whatsoever
  • i'm using "gnome-fallback" (gnome classic 2D)

what actions does gnome execute when clicking on eg. logout exactly? i want to trace these steps

any help is appreciated very much!

5
  • 1
    Try "tail -F" with ~/.xsession-errors and/or look at ~/.xsession-errors.old after reboot. There might be some indication in there. Also, if you are seeing the splash while it is waiting (the Ubuntu logo and the dots), then remove "quiet" and "splash" from the kernel boot arguments to have more information while it is hanging. This might be related to mounted network shares.
    – blueyed
    Jun 2, 2012 at 20:57
  • thank you, i will investigate .xsession-errors (there are a lot of different messages). the hang is not when the ubuntu logo is displayed but i still see the desktop or some foreground program. and i have not network shares
    – Flo Hallo
    Jun 3, 2012 at 20:29
  • Are you using Squid (a HTTP proxy) by any chance? This might add 30 seconds (shutdown lifetime, can be configured to be 0).
    – blueyed
    Oct 9, 2013 at 0:34
  • 1
    Using bootchart will show you what's happening at boot at least, example bootchart.org/samples.html#Debian. Though it does take some interpreting. You can "sudo apt-get install bootchart". Flicking to a console, eg Ctrl+Alt+F1, and watching "less +F /var/log/syslog" (or use tail) will give you some ideas what is happening at logout too.
    – pbhj
    Nov 19, 2014 at 22:43
  • This might be a long shot but have you tried checking your hdd for errors? Something like Seagate's Seatools or check if your SMART has been triggered. Sometimes the Matrix is lurking...
    – warhansen
    Apr 8, 2016 at 12:11

1 Answer 1

0

You said that there is no waiting time when you type sudo reboot, right? Well, if that's the case, you can just open up gedit, type in sudo reboot, save it as a .sh file, make it executable and put it in an easily accessible place. Also, make sure to run it in terminal so you can type in the password.

1
  • 1
    That's not really a solution, since it doesn't shut down sessions cleanly. Nov 30, 2014 at 16:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .