I just decided to install Ubuntu 12.04 alongside Windows 7 on my Dell laptop. However I didn't do this manually but instead used the "Install Ubuntu alongside Windows 7" option during the installation. Now the partition that Ubuntu runs in has very little space and I am getting warning messages.

I'm trying to use gparted 0.12.1-5 (via a live CD) to give Windows less space and give Ubuntu more. I've managed to remove 100GB from the Windows partition so I now have some unallocated space between Windows and Ubuntu.

This is what it looks like inside Ubuntu (not using the live CD, since it won't let me mount a USB to save a screenshot):

screenshot of gparted showing drive's partitions

So first I take sda4 (extended?) and resize it to the left so it takes up all the unallocated space. Then I resize sda5 (ext4) as well so it takes up all the new space.

However, when I hit apply, it fails on the first action (resizing sd4) with the error message can't have overlapping partitions.

Any ideas as to why this happens? I also tried resizing sda4 by just a few MB so that it definitely didn't overlap anything, but I still got the same error message.

To clarify, I am using gparted from the LiveCD, I just took the screenshot from Ubuntu.

I couldn't attach the details file containing the error information from gparted because I can't mount a USB drive when I'm running from the LiveCD.

I'm tried following the guide on the gparted website but it says Invalid argument or something like that. If the gparted details are needed, I may need some hints on how to solve the USB issue as well. :)

  • I have the same problem. Did you find a good work around for when GParded failed with this error? – Lii Jan 23 '13 at 0:16

The last post of this thread http://ubuntuforums.org/showthread.php?t=1980664 solved the problem for me.

When looking at the dialog box for "resize/move dev/sda2" there is an option to change the alignment from MiB to Cylinder - click to change it and... Voilà! To resize my sda1 (windows), I had to switch back to MiB.

|improve this answer|||||

This problem appears to be the same as the following bug report:

Bug #678831 - Partition End Overlap when Resizing Extended Partition


This bug report is scheduled for inclusion in the upstream release of GParted 0.13.0 on Friday, July 13, 2012.

|improve this answer|||||
  • The GParted Live 0.13.0-beta1.3 is available upstream now. The stable release of GParted Live is expected a few days after the application release date. – Curtis Gedak Jul 13 '12 at 0:41

Some suggestions.

  1. You are probably already doing this, but I'll mention it "just in case".

    Before you attempt to resize /dev/sda4 (or any partition inside of it), you must use swapoff within gparted to ensure that the swap partition, /dev/sda6, is unlocked.

    If you do not do this your LiveCD will automatically lock and use it. This would prevent you from changing it.

  2. One way you could make a copy of the error results from gparted would be to copy the file onto your sda5, Ubuntu, partition.

    While using the LiveCD, open the file manager, mount the Ubuntu 2.87 GB partition by clicking on it, and then copy the gparted results file to sda5.

    For example, you could copy the file into your /home/userid or /home/userid/Documents directory. After you have made a copy, change the permissions of the copy to allow anyone to read and write to it. (This will allow you to work with the file without using sudo, later, when you are not using the LiveCD.

  3. Your swap partition is 5.9 GiB while your / (Ubuntu) partition is only 2.87 GiB. This is absurd.

    The installer probably did this to you. It may have attempted to create a swap which was the same size as your memory. This is only important if you want to hibernate your machine. If you do not hibernate you can use a much smaller swap (or even no swap partition at all if you have 'enough' memory).

    I suggest you try the following using gparted after booting your LiveCD.

    • Ensure the swap partition is not locked. (See (1) above).
    • Delete the swap partition /dev/sda6.
    • Create a "new" swap partition no bigger than, say, 1 GiB (1024 MiB) at the END of the unallocated space inside sda4.
    • Resize your Ubuntu partition, sda5, to use the unallocated space now available in front of the new swap partition you created.

    The above steps should give you a few more GiB of breathing room for sda5 until you can figure out why you cannot expand sda4.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.