1

i have an NTFS drive mounted in a folder /Tejas i have created a new project using it in a folder in this drive but i am unable to save the changes, i get the following error message

Couldn't save project /Tejas/Project/codeblock/ciphers/ciphers.cbp
(Maybe the file is write-protected?)

i get similar message even when i try to save the c source file

i am able to edit and save files using gedit editor... why am i getting this problem?
EDIT:
i have modified my fstab and added this line

/dev/sda5/Tejas ntfs uid=1000,gid=1000,defaults,umask=000 0 0

but it still doesn't seem to work not working

1

I found this thread and perhaps can save you from all this.

It is marked as SOLVED So it will surely solve your problem.

Q. Why I just put link here?
A. It doesn't worth copy and paste things.

Edit 1 : it should be like this,

/dev/sda5 /media/Tejas ntfs defaults,uid=YYYY,gid=XXXX,umask=007 0 0

YYYY your user id, XXXXyour group id.

create folder Tejas if it's not there in /media/ by issuing

sudo mkdir /media/Tejas

Edit 2 : you can try

/dev/sda5 /media/Tejas ntfs-3g defaults,umask=000 0 0

or

/dev/sda5 /media/Tejas ntfs-3g defaults,uid=YYYY,gid=XXXX,umask=007 0 0
  • is this correct /dev/sda5/Tejas ntfs uid=1000,gid=1000,defaults,umask=000 0 0 – ths Jun 2 '12 at 17:43
  • /dev/sda5 /media/Tejas ntfs defaults,uid=1000,gid=46,umask=007 0 0 – Rahul Virpara Jun 2 '12 at 17:48
  • uid= your user id, gid= your group id – Rahul Virpara Jun 2 '12 at 17:49
  • create folder Tejas if it's not there in /media/ by issuing sudo mkdir /media/Tejas – Rahul Virpara Jun 2 '12 at 17:50
  • all the mounting stuff is working i can access files even create and delete files documents etc... but code blocks says that it cant save files. i have put uid and gid from the command "id username" – ths Jun 2 '12 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.