21

I'm using Ubuntu 12.04. If I switch on "Auto-hide launcher", it hides but does not reveal with the pointer, and only comes back on switching off auto-hide.

closed as off-topic by Braiam, Warren Hill, Avinash Raj, Eric Carvalho, psusi Dec 15 '13 at 18:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Warren Hill, Avinash Raj, Eric Carvalho, psusi
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Does it appear when you use the Super key? – TenorB May 18 '12 at 5:35
  • 5
    Which version of Unity are you using - 3D or 2D? Also, are you running on bare hardware or inside a VirtualBox session? I found a couple bugs that might possibly be relevant (Bug 989477, Bug 971018) but I can't be sure which you're experiencing unless you provide some more information. Thanks! – Christopher Kyle Horton Jun 2 '12 at 19:23
  • I suspect you're using a multi-screen setup. I have seen this issue as well. I just use the super key to work around it. If you put the launcher on the left-most screen it evidences much less often – RobotHumans Jun 3 '12 at 11:01
  • 3
    @ChristopherKyleHorton Thank you for the hints. For all those using Ubuntu in VirtualBox disable "Mouse integration" option if you want Unity launcher to re-appear when Auto-Hide is enabled. Tested with VirtualBox version 5.0.22 r108108 and Ubuntu 16.04. More info about this issue can be found on the related bug report page. – informatik01 Jun 27 '16 at 14:23
  • 1
    That was exactly my problem, thanks @informatik01 – Alexander Fradiani Dec 29 '16 at 19:02
29

Thanks to "Warrioring 64". I found my solution in replies to BUG 9894477. Launcher reappears:-

  1. By pressing Alt+F1
  2. By pressing super key.
  3. By striking the left side with the pointer 3/4 times quickly.
  4. By moving your pointer towards the left end and when you reach the left end, don't stop and just keep moving left (as if you're trying to push the mouse out of the screen).
  • 1
    What you pointed out at 3. lets me assume that it could be solved via editing the Launcher Reveal Pressure with CCSM. Did you try that? – Jakob Jun 5 '12 at 21:13
  • (1.) works for this same problem in Scientific Linux – FSchmidt Nov 30 '13 at 0:15
  • Amusingly, this bug persists in 14.04 and I had no access to any apps; I had to google on my phone for a solution. Which was to hit alt-f1 and then disable auto-hide, as it's broken. – user12753 Mar 15 '15 at 22:21
  • Still an issue with 15.10. – aalaap Aug 31 '15 at 13:46
  • Still an issue with 16.04.3 LTS. Only 2. worked for me (hitting the 'Windows' button). – copper.hat Dec 14 '17 at 17:42
5

Could it be this bug?

Install CompizConfig Settings Manager Install compizconfig-settings-manager and start CCSM. Edit Ubuntu Unity Plugin and inside the Experimental Tab set Launcher Reveal Pressure to "1" (instead of "20" - default).

enter image description here

But be aware: CCSM is an advanced tool. Use with caution. This tool allows you to deeply configure Compiz's settings. Some options may be incompatible with each other. Unless used with care, it is possible to be left with an unusable desktop.

  • This solved it for me. Changing settings in appearance does not work. – Heisenberg Sep 11 '14 at 23:00
  • 2
    Did not work for me on Ubuntu 14.10. – Ponkadoodle Nov 3 '14 at 3:11
  • worked for me ubuntu 14.04 – joniba Oct 24 '15 at 16:07
2

With Ubuntu 12.04, my launcher stopped revealing when I pushed my mouse to the left side of the screen. This happened after I changed several CompizConfig Settings Manager settings to completely resolve a "sticky-edges" problem among multiple displays.

The problem was that I had set the "edge stop velocity" to 1. After I returned this value to its default (65), my launcher behaved normally again. The edge stop velocity description reads, "The maximum velocity at which the mouse will be stopped," so I think my launcher wasn't revealing because my pointer was always moving to fast to register as a "stop" on the left side of the screen. Whatever the reason, play with this value if the launcher isn't popping up and everything else seems normal.

1

Go to System Setting --> Appearance --> Behavior

Now you can enable/disable auto-hide and Reveal Sensitivity.

0

I had this problem too. Go to System Settings > 'Appearance'. Select the tab 'Behaviour' and switch OFF the fade out function.

Alternatively adjust the sensibility of the reveal. The higher the bar, the faster you have to scroll to the side to let the Launcher appear.

  • I think your answer is essentially the same as Shekhar's but the descriptions used for naigating the GUI do not match the names used in the English version of Ubuntu. Please consider editing your answer to improve it. – irrational John Jun 2 '12 at 20:55
-2

Well i faced this problem too...The solution I followed??

This might not be the exact solution you want but if nothing else works,you may use this-

I loved the dodge window feature more...I brought it back through compiz...

If you also like it or wish to add and use it, do the following-

  1. Install CompizConfigurationManager via the SoftwareCenter if you do not have it

  2. enter the following commands in the terminal one by one-

sudo apt-add-repository ppa:ikarosdev/unity-revamped    
sudo apt-get update && sudo apt-get dist-upgrade

You will find the feature in the "Ubuntu Unity Plugin" option.

1:

plugin1

2:

plugin2

Not the answer you're looking for? Browse other questions tagged or ask your own question.