3

I have an HP Envy x360 15-ew0023dx that I installed Ubuntu 22.04 on, and the speakers do not play audio at all. Headphones work if plugged in. The command lspci shows 00:1f.3 Multimedia audio controller: Intel Corporation Alder Lake PCH-P High Definition Audio Controller (rev 01).

I've seen a million posts about Alder Lake audio not working right on various Linux distributions, but all the ideas I've seen either don't fix the problem or are too complicated for me to even attempt.

I tried installing the latest mainline kernel 6.1.11, seeing that some issues with Intel audio were fixed in later kernels, but it didn't help.

I've been trying to install sof-firmware-signed 2.2.4. I installed the .deb file, but I'm not sure if it worked. Is this line in lspci supposed to change to sof-firmware-signed for the audio controller: Kernel driver in use: sof-audio-pci-intel-tgl?

Does anyone have any suggestions for how this could be fixed? Or possibly a Linux distribution that audio is likely to work on? I like Ubuntu and have never tried another, but I'm willing to.

enter image description here

Edit: While I no longer have this laptop (partly because of this issue), I'll add links to two bug reports related to the issue, for others' reference:

11
  • Have checked your output device in settings/sound?
    – stumblebee
    Feb 13, 2023 at 22:32
  • I added a picture. It seems like everything is working there. The output device bars show bars for loudness when there is a video playing, but there is no sound. Using Test on headphones works, but not on speakers. And there are no other options under Output Devices.
    – Dima
    Feb 13, 2023 at 22:46
  • I recommend running - mv ~/.config/pulse/ ~/.config/pulse.old and systemctl --user restart pulseaudio This is a safe and simple way to reset audio settings.
    – stumblebee
    Feb 14, 2023 at 0:06
  • @stumblebee I did that and then restarted. No change.
    – Dima
    Feb 14, 2023 at 1:10
  • Go back to output device in settings/sound and recheck. if that is all set correctly, Run alsamixer and check settings there. You will need to use up and down arrow keys to maneuver around and adjust settings. Press <ESC> to exit the program.
    – stumblebee
    Feb 14, 2023 at 1:33

0

You must log in to answer this question.

Browse other questions tagged .