5

I have a Serial interface board (Buslinker 2.5) form HiWonder used to control LX-16A servo motors. I am having trouble getting it to connect to my USB port on my Linux machine. It does connect once in a while and while I am using it, it seems to work well. But it usually will not connect. I can see the device with lsusb but this only tells me that it is visible from my terminal.

I ran the dmesg | tail -10 so that I could watch the connection and this is what transpired. (I left off the date/time code for clarity)

As you can see in line 5, the device connects to ttyUSB0 but then below that line something is not happy about that connection and kicks off.

usb 1-2: new full-speed USB device number 15 using xhci_hcd
usb 1-2: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
usb 1-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
usb 1-2: Product: USB Serial ch341 1-2:1.0: ch341-uart converter detected
usb 1-2: ch341-uart converter now attached to ttyUSB0
input: BRLTTY 6.4 Linux Screen Driver Keyboard as /devices/virtual/input/input57
usb 1-2: usbfs: interface 0 claimed by ch341 while 'brltty' sets config #1
ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
ch341 1-2:1.0: device disconnected

I was hoping someone with superior knowledge could help me troubleshoot this problem.

Thank you for listening.

Clan

2

2 Answers 2

8

I did find out there is a service running on my POP OS Linux system that is used for blind people. It is called brltty. (Not exactly sure what is does) It seems that the suggested way to eliminate this problem is to disable the service as below. (It worked for me)

Listing 2: Disabling brltty service 
$ sudo systemctl stop brltty-udev.service
$ sudo systemctl mask brltty-udev.service
Created symlink /etc/systemd/system/brltty-udev.service → /dev/null.
$ sudo systemctl stop brltty.service
$ sudo systemctl disable brltty.service
Unit /etc/systemd/system/brltty.service is masked, ignoring.

Hope this will be usefull for others with the same problem.

Clan

1
  • cant comment because low rp, Authors answer works, but ``` $ sudo systemctl stop brltty-udev.service $ sudo systemctl mask brltty-udev.service ``` is probably enough. more info about masking is here: askubuntu.com/questions/816285/…
    – numan
    Jan 29 at 7:09
0

It happen due to brltty accessibility service for blind people that is installed in Ubuntu and Ubuntu derivatives (Mint etc.) by default and have priority over serial devices plugged into the system later. Simply disable or remove this service.

sudo apt remove brltty

Then unplug your adapter from system and plug it back again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .