I installed ubuntu using Wubi side by side with Windows. I decided to uninstall ubuntu and install Kubuntu, which I did successfully. However now when I boot my computer, the Windows Boot Manager displays 3 options:

  • Windows
  • Ubuntu
  • Kubuntu

The Ubuntu option does not work, but the entry did not get removed when I uninstalled Ubuntu the first time. How do i get rid of this extra entry?

  • Did you try running "sudo update-grub"? – harisibrahimkv Jun 2 '12 at 11:21

For Windows Vista, 7 or 8, run bcdedit as an administrator (hit Windows key, type cmd, look above and right-click CMD.EXE and select Run as administrator).

This will list the Windows Boot Manager entries:


Windows Boot Manager
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {1476af5e-e5bc-11de-b180-0024543ae029}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 10

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {1476af60-e5bc-11de-b180-0024543ae029}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \windows
resumeobject            {1476af5e-e5bc-11de-b180-0024543ae029}
nx                      OptIn

Real-mode Boot Sector
identifier              {1476af63-e5bc-11de-b180-0024543ae029}
device                  partition=C:
path                    \ubuntu\winboot\wubildr.mbr
description             Ubuntu


Note the Real-mode Boot Sector entry that has a description of Ubuntu. Copy and paste the identifier and then delete it as follows (in my case):

bcdedit /delete {1476af63-e5bc-11de-b180-0024543ae029}

For Windows XP, you can edit C:\boot.ini. I recommend making a backup first as an error can prevent Windows from booting. Also you should edit it as follows:

  1. Right-click My Computer, and then click Properties.
  2. On the Advanced tab, click Settingsunder Startup and Recovery.
  3. Under System Startup click Edit.
  4. Delete the line C:\wubildr.mbr = "Ubuntu"
  • C:\Windows\System32>bcdedit.exe The boot configuration data store could not be opened. The system cannot find the file specified. -- Windows 7 Ultimate 64-bit. :\ – delaccount992 Aug 18 '12 at 16:51
  • @Kobie, see this: askubuntu.com/q/73585/14916 – bcbc Aug 18 '12 at 22:08
  • This method also works in Windows 10, FYI – user567152 Jul 11 '16 at 18:15
  • This method works perfectly for other operating systems in the Real-mode Boot Sector (Remix OS in my case) – miva2 Aug 29 '16 at 12:35

You could use Grub Customizer, a graphical grub2 settings manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.