I know that for such new hardware would be better to use a rolling release distro or at least the latest 22.10, but I was wondering if with some tinkering it is still possible to get the latest LTS to work.

As far as I know, to get a 7900 XTX to work on linux you need at least these:

  1. Kernel 6.x+
  2. LLVM 15+
  3. Mesa 22.3+
  4. latest linux-firmware for /lib/firmware/amdgpu/ (and rebuild initramfs)

Is it possible and, if yes, what would be the best way to achieve this on Ubuntu 22.04 LTS?

2 Answers 2


To get an AMD Radeon RX 7900 XT(X) to work with Ubuntu 22.04 LTS, you can follow these steps:

  1. Install the latest OEM kernel available by running the command:
sudo apt install linux-oem-22.04c
  1. Download and install the latest kernel firmware from here by running these commands:
wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-20230117.tar.gz
tar -xf linux-firmware-20230117.tar.gz
sudo cp linux-firmware-20230117/amdgpu/* /lib/firmware/amdgpu/
sudo update-initramfs -uk 'all'
  1. Install the kisak-mesa PPT by running these commands (this PPA will take care of providing the latest stable mesa and llvm15):
sudo add-apt-repository ppa:kisak/kisak-mesa
sudo apt upgrade
  1. Ensure there is no modprobe blacklist for amdgpu by running the command:
sudo rm /etc/modprobe.d/blacklist-amdgpu.conf

If you use Xorg instead of Wayland and have the issue where the mouse cursor is invisible, you can try to create the file /etc/X11/xorg.conf.d/99-modesetting.conf with the following content:

Section "Device"
      Identifier "modesetting"
      Driver "modesetting"

This should make the latest LTS work with your hardware.

  • For every apt install/upgrade operation, dkms tries to rebuild the driver wrapper and fails. This leaves me with a /etc/modeprobe.d/blacklist-amdgpu.conf after every apt operation pretty much.
    – MadMan2064
    Jan 27 at 2:39
  • I'm not experiencing this issue (just tested to ran apt update && apt upgrade). Do you have any other PPAs or dynamic kernel modules that may cause this? Jan 27 at 6:04
  • If you use the amdgpu primary drivers I believe they have a dkms component to it. 'amdgpu-install --usecase=graphics,....' The performance improvement is quite substantial.
    – MadMan2064
    Jan 28 at 2:51
  • What do you mean by "amdgpu primary drivers"? Do you mean the amdgpu-pro, the one that you download from the AMD website? Or are you talking about the open source amdgpu from Mesa? I'm using the latter and I never heard about this extra step. Can you please link some documentation about it? Jan 28 at 10:03
  • Performance goes up from 6kfps to 13kfps using the AMDGPU stack with glmark2. amdgpu-install.readthedocs.io/en/latest amd.com/en/support/linux-drivers
    – MadMan2064
    Jan 29 at 22:50

As @MadMan2064 mentioned in the comments, amdgpu-install from https://www.amd.com/en/support/linux-drivers worked for me with a Radeon RX 7900 XT. Even though I'm on Ubuntu 22.10 (kinetic), the 22.04 version worked. I installed the .deb file and ran amdgpu-install without any arguments, and that was sufficient. No need to install a special kernel or add a ppa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.