3

A few days ago I updated Ubuntu 22.10 and when I rebooted the system I had the following issues:

  1. The computer couldn't connect to the internet in any way (with wi-fi, with ethernet or with usb)
  2. The bluetooth adapter wasn't detected either
  3. The refresh rate of the screen was set to 60hz (normally it's in 144hz) and NVIDIA X Server settings is not detecting my GPU anymore

If I go to the advanced settings in GRUB, I can see that the system is booting in Ubuntu, with Linux 5.19.0-1015-oracle. If I boot in the other option available in the menu (Ubuntu, with Linux 5.19.0-29-generic) everything works great again. Is this some kind of issue with the Kernel? In that case, what should I do to fix it?

Edit: if I run dkms status in the working kernel it shows the following xpad/0.4, 5.19.0-29-generic, x86_64: installed
Just to clarify: I never tried to install any additional kernel or anything like that. I have no idea of what is this oracle kerneltree/oracle cloud infrastructure. I only installed some programs in .deb and flatpak packaging format but nothing else.
Could it be that this auto-installed by itself with the update or something like that? And should I do something to uninstall it?

Edit 2:
this is the output of dpkg -l | grep oracle:

ii  linux-image-5.19.0-1015-oracle                  5.19.0-1015.17                            amd64        Signed kernel image oracle  
ii  linux-modules-5.19.0-1015-oracle                5.19.0-1015.17                            amd64        Oracle Linux kernel extra modules for version 5.19.0 on 64 bit x86 SMP  
ii  linux-objects-nvidia-525-5.19.0-1015-oracle     5.19.0-1015.17+1                          amd64        Linux kernel nvidia modules for version 5.19.0-1015 (objects)  
ii  linux-signatures-nvidia-5.19.0-1015-oracle      5.19.0-1015.17+1                          amd64        Linux kernel signatures for nvidia modules for version 5.19.0-1015-oracle  

and this is the complete output of sudo apt update:

Obj:1 https://repo.steampowered.com/steam stable InRelease
Obj:2 http://packages.microsoft.com/repos/code stable InRelease                                           
Des:3 http://security.ubuntu.com/ubuntu kinetic-security InRelease [109 kB]                   
Obj:4 http://ar.archive.ubuntu.com/ubuntu kinetic InRelease                                                                      
Obj:5 http://ar.archive.ubuntu.com/ubuntu kinetic-updates InRelease                                                              
Obj:6 http://ar.archive.ubuntu.com/ubuntu kinetic-backports InRelease                       
Obj:7 https://ppa.launchpadcontent.net/appimagelauncher-team/stable/ubuntu kinetic InRelease
Des:8 http://security.ubuntu.com/ubuntu kinetic-security/main amd64 DEP-11 Metadata [28,5 kB]
Des:9 http://security.ubuntu.com/ubuntu kinetic-security/universe amd64 DEP-11 Metadata [1.436 B]
Descargados 139 kB en 2s (65,7 kB/s)          
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado... Hecho
Se pueden actualizar 33 paquetes. Ejecute «apt list --upgradable» para verlos.
8
  • Boot up the working kernel and show dkms status add this to your question please edit and do you really need this oracle kerneltree?
    – nobody
    Jan 22 at 14:49
  • Are you running on Oracle Cloud Infrastructure? If no, you should boot the normal kernel. Jan 22 at 15:06
  • 1
    Can confirm - this happened to me too on a Lenovo P1 Gen2 and 22.10. Was suspicious about the kernel, your post helped me temporarily resolve this - choosing 29-generic worked for me. (GJ Google for indexing this so quick.) Seems like the oracle kernels are for Oracle Cloud systems, I do wonder why it was auto-installed on my machine.
    – advance512
    Jan 22 at 15:13
  • Please edit your question to show us the complete output of sudo apt update. It may be lengthy -- show us all of it.
    – user535733
    Jan 22 at 17:27
  • 1
    Please remove the 4 packages with oracle in name.
    – nobody
    Jan 22 at 22:15

1 Answer 1

1

After using Advanced options for Ubuntu on boot and choosing a non-oracle Kernel, the following command solved it for me permanently (by uninstalling all packages with 'oracle' in their name and its additional data files):

dpkg -l | grep oracle | awk -F ' ' '{print $2}' | while read line ; do sudo apt -y purge $line ; done;

You can also run the following command to confirm what will be removed, prior to running the purge command:

dpkg -l | grep oracle | awk -F ' ' '{print $2}' | while read line ; do echo "sudo apt purge $line" ; done;

P.S. - Pretty odd that some of those leaving comments above write to you as if you chose to install an Oracle Cloud kernel. :facepalm: Ubuntu in 2023..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.