I configured ubuntu to hibernate using the guide in the link Everything Appears to work fine except for the fact that my system keeps resuming from hibernation immediately after a successful hibernation. The only line that changed n my grub config: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=2f8581dc-9788-414c-8525-5f844eed53df resume_offset=4603904"

System Info

system info linked here

  • Is the MacBook using WiFi or Ethernet? If it’s the latter, Wake-on-LAN may be interfering 🤔
    – matigo
    Jan 22 at 13:11
  • Check /proc/wakeup ; switch all to disable witch echo NAME > /proc/wakeup
    – Adam
    Jan 22 at 13:31

1 Answer 1


@Adam is right. It was the laptop lid (LID0) in my case that was making the system resume instantly. I disabled it using the command echo "LID0" > /proc/acpi/wakeup. Thanks!

  • Is this a MacBook?
    – Seamus
    Jan 22 at 23:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .