0

I have been trying to use this code in UBUNTU :

wget https://snpeff.blob.core.windows.net/versions/snpEff_latest_core.z
unzip snpEff_latest_core.zip
java -Xmx8g -jar snpEff.jar GRCh37.75 data_1.vcf > test.chr22.ann.vcf

It worked well until the java command.

Command 'java' not found, but can be installed with:
sudo apt install openjdk-11-jre-headless  # version 11.0.16+8-0ubuntu1~22.04, or
sudo apt install default-jre              # version 2:1.11-72build2
sudo apt install openjdk-17-jre-headless  # version 17.0.3+7-0ubuntu0.22.04.1
sudo apt install openjdk-18-jre-headless  # version 18~36ea-1
sudo apt install openjdk-8-jre-headless   # version 8u312-b07-0ubuntu1

I tried every option listed above but they all failed:

Err:1 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 alsa-ucm-conf all 1.2.6.3-1ubuntu1.1
  404  Not Found 
Ign:2 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 openjdk-11-jre-headless amd64 11.0.16+8-0ubuntu1~22.04
Err:2 http://security.ubuntu.com/ubuntu jammy-updates/main amd64 openjdk-11-jre-headless amd64 11.0.16+8-0ubuntu1~22.04
  404  Not Found 
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-ucm-conf/alsa-ucm-conf_1.2.6.3-1ubuntu1.1_all.deb  404  Not Found [IP: 185.125.190.36 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/o/openjdk-lts/openjdk-11-jre-headless_11.0.16%2b8-0ubuntu1%7e22.04_amd64.deb  404  Not Found 
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Is there any way to fox this so i may use the code ? Thank you:)

2
  • 1
    Did you try the advice in the message (maybe run [sudo] apt-get update)? Commented Jan 22, 2023 at 13:34
  • Just to clarify, run the command sudo apt-get update and try again. Commented Jan 22, 2023 at 18:10

0

You must log in to answer this question.

Browse other questions tagged .