3

I'm using stock Ubuntu 22.04 with default installation of Gnome and Wayland on ThinkPad T14 (Intel graphics). I have disabled screen blanking in all places that I could find. System respects my will and does not turn the screen off no matter how long I will remain inactive.

This all changes when I connect an external display (using a Thunderbolt-attached docking station). After I connect that display the system starts to ignore all my settings and simply blanks all of the screens after 30 seconds. It seems to be done on a level lower than Gnome - there's no dimming animation that Gnome uses, it simply goes straight to black.

The problem persists in some way when I disconnect the external display. Instead of going black the display "freezes" and I need to interact with the computer in order for it to update. The only way to fix this is to just reboot the computer.

This problem has been described in the past, but all the suggested solutions are meant to work with the X server and do not work under Wayland (e.g. using xset s off -dpms). Is there a solution other that just using X11?

2
  • When it freezes after blanking, have you tried switching to another console/tty then back? I have a case where wayland get back.
    – user.dz
    Jan 30, 2023 at 5:34
  • 1
    @user.dz I did not try that as all I need to do in order to "unfreeze" the screen is to move the mouse pointer or press a key on the keyboard. Jan 30, 2023 at 7:52

1 Answer 1

0

Usually this problem is caused by the screenlocker/screensaver.

Many Desktop Environments will try to run one of the following (whatever it finds first, the order depends on the DE):

  • xfce4-screensaver-command --lock
  • xscreensaver-command -lock
  • light-locker-command --lock
  • gnome-screensaver-command --lock
  • mate-screensaver-command --lock

Installing a different one may fix your problem.

Note that you will have to uninstall the other. If you can't uninstall it, then backup the file and make a symlink (e.g. symlink gnome-screensaver-command to mate-screensaver-command)

If the problem persists I suggest you report a bug to upstream of the screensaver you are using.

2
  • Screensaver is already disabled and does not activate when no external monitor is connected. Feb 1, 2023 at 15:22
  • Regardless, it looks like the screensaver ignores your disabled option when you connect the external mon. If you physically remove the commands; your system will not be able to to use screensaver at all and if that works you've found the culprit. If it doesn't work, you now know it is not related to it. Feb 1, 2023 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .