0

I am trying to install python3-venv with sudo apt-get install python3-venv and I get

The following packages have unmet dependencies:
 python3.10-venv : Depends: python3.10 (= 3.10.6-1~22.04) but 3.10.6-1~22.04.2 is to be installed
E: Unable to correct problems, you have held broken packages.

I don't know why I have the 22.04.2 version of python, I am on the standard 22.04.1 LTS version of Ubuntu.

$ apt policy python3.10
python3.10:
  Installed: 3.10.6-1~22.04.2
  Candidate: 3.10.6-1~22.04.2
  Version table:
 *** 3.10.6-1~22.04.2 100
        100 /var/lib/dpkg/status
     3.10.6-1~22.04 500
        500 http://ubuntu.mirror.su.se/ubuntu jammy-updates/main amd64 Packages
     3.10.4-3ubuntu0.1 500
        500 http://ubuntu.mirror.su.se/ubuntu jammy-security/main amd64 Packages
     3.10.4-3 500
        500 http://ubuntu.mirror.su.se/ubuntu jammy/main amd64 Packages
0

1 Answer 1

0

The problem was with the repository. I've changed it to Main and had a bunch of packages updated. And now python3-env is up to date.

Not the answer you're looking for? Browse other questions tagged .