0

My system is old and bios only. However, I created a dual-boot setup on SSD for Ubuntu 22.04 LTS and Windows 10 in GPT format. Yes, I got it to work. Everything worked fine until I plugged the old HDD back in. At that point, Grub 2 went into Rescue Mode. The old drive has the same setup (dual boot Windows 10 and Deepin 15), except it currently boots straight to Windows 10. I still want to be able to boot the old HDD setup by choosing the drive as the first boot option in the bios or having the SSD Grub2 detect all of them.

  1. I didn't think Grub would auto-adjust the boot options, but it must have tried. Does it auto-change if something is found? I thought you had to execute grub-update to make changes.

  2. How do I fix this mess? I'm not ready to erase the old HDD and lose the existing operating systems on it just yet, but I want to still boot all four somehow. And, I don't want to constantly unplug the HDD.

7
  • Need to see details: Please copy & paste the pastebin link to the BootInfo summary report ( do not post report), do not run the auto fix till reviewed. Use often updated ppa version over somewhat older ISO with your USB installer or any working install. help.ubuntu.com/community/Boot-Repair & sourceforge.net/p/boot-repair/home/Home
    – oldfred
    Jan 11, 2023 at 21:48
  • Pastebin Link
    – salmmus
    Jan 11, 2023 at 23:39
  • "sda" is the GPT SSD (the new drive w/Ubu22.04 and W10). "sdb" is the old HDD w/Deep15 and W10). "sdc" is the USB that boots Win 10 (SSD) to UEFI. I double-space but it isn;t line breaking.
    – salmmus
    Jan 11, 2023 at 23:50
  • System is not so old as to be BIOS only. You have both UEFI & BIOS installs. Line 217. Rerun report when booted in UEFI mode. Both sda & sdb are gpt, so should be UEFI. sdc is old MBR(msdos) and seems to only have an old BIOS boot Windows partition. Windows only booots from gpt with UEFI and you show Windows boot files in both ESPs. Did you change UEFI/BIOS to BIOS and install grub to MBR? Boot Boot-Repair in UEFI mode & reinstall grub in UEFI mode & make sure UEFI default boot mode is UEFI. You also seem to have duplicate GUIDs/partUUIDs in sda. lines 392-394, that is not allowed.
    – oldfred
    Jan 12, 2023 at 3:38
  • A few tools make Ubuntu live installer UEFI only or BIOS only. You want one that is either both or UEFI only. Then in UEFI boot menu, you should have two choices, if live installer created as both. One clearly UEFI as UEFI:XXX and another XXX which is the BIOS boot option. Windows could not have installed boot files into ESP unless you isntalled in UEFI boot mode. It only uses UEFI with gpt partitioning and only BIOS with old MBR partitioning. If system is less than 10 years old, it is UEFI as Microsoft required vendors to install in UEFI mode with release of Windows 8 in 2012.
    – oldfred
    Jan 12, 2023 at 21:17

0

You must log in to answer this question.

Browse other questions tagged .