So I installed Ubuntu 12.04 alongside Windows XP on my netbook via a usb (since it doesn't have a DVD/CD drive).

At the end of the installation, I got an error saying the bootloader couldn't be installed, but I selected the hard drive and everything seemed ok.

However, whenever I turn on the computer, it goes straight to Windows XP. And when I go to the OS selection screen during startup, Ubuntu is not there.

I heard that you can fix this problem through booting up Ubuntu again with the flash drive. However, when I boot through the flash drive, it gives me the options of trying without installing, installing, etc.

I really have no idea where to go from here, can anyone please help out? Thanks!

  • When you turn on your netbook, press down shift, and keep it pressed down as soon as the BIOS screen comes up. Will that bring up the Grub menu? – Mitch Jun 1 '12 at 6:41
  • Nope, no Grub menu there. – Mike Jun 1 '12 at 6:55

I had the same experience as the OP with two main differences:
1) Desktop machine with two physical HDDs.
2) Windows XP was installed on the first HDD.

Instead of messing with the boot loader, all I had to do was change the order of the drives listed in the BIOS so that #1 was the HDD with Ubuntu installed, and #2 was the WinXP drive.

After doing so I was presented with the linux version of the boot selector, and could choose Ubuntu or WinXP as I had originally desired.

I'm not sure if this will apply to the original question, but it may be useful for others.


Sounds like grub is not installed right. This could solve your problem:


  • Just want to make sure, so I boot Ubuntu from the flash drive (selecting trying it without install) and typing these two lines into terminal?: sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update -AND- sudo apt-get install -y boot-repair && boot-repair – Mike Jun 1 '12 at 6:58
  • I tried this, but it unfortunately did not work. I did the installation via terminal, but typing "boot-repair" to launch it via terminal brings the message "command not found" – Mike Jun 1 '12 at 7:06
  • what was the output of the apt commands? – Steve Jun 1 '12 at 8:02
  • @Mike I tried to outline the steps for installing & running boot-repair in this answer. Perhaps it will help? Note: That answer describes how to use boot-repair to collect a BootInfo summary and post it to paste.ubuntu.com. This is what I would suggest you do first. But whatever way you go, please post the URL to the pastebin boot-repair creates. You must (1) be connected to the Internet and (2) allow boot-repair to install the pastebinit utility in order to create a pastebin we can use to provide further help. – irrational John Jun 1 '12 at 19:11

For whatever reason Ubuntu didn't install boot loader 'Grub2' while you installed that OS. So now you have left with the Windows boot loader.

The solution is to boot into the Live mode. (Select 'Try Ubuntu') Then follow the steps given here:


It's a long post but definitely worth to read relevent part. So that even in future it's of great help.


First you have to check the partition that Ubuntu OS was installed(In Computer Memory management option), If you doesn't found you have to repair or re-install Ubuntu. You don't specified that Windows7 is working or not..? or otherwise follow this below link, it gives you remaining information about your boot failure https://help.ubuntu.com/community/Boot-Repair..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.