I just bought a game called Limbo in Humble Bundle V. The site says that all games are cross-platform but in my computer the game has no sound. I've searched in google and looked in the official FAQ, but none of them helped me.

How can I fix this?

  • I too have this issue and it's quite annoying. Running the 64bit .deb package from the Humble Bundle V. Considering how much emphasis that is on the immersive sound effects this basically renders the game unplayable (or at least not as enjoyable as it should be).
    – user67699
    Jun 1, 2012 at 13:01

8 Answers 8


I got sound working after killing pulse audio. You'll have to get rid of the autospawn feature though.

See : http://forum.winehq.org/viewtopic.php?t=1457&sid=b61a832efcbda1807f7d3791e7a46a67


sudo nano /etc/pulse/client.conf

(Or use editor of choice instead of nano.)

Uncomment and change the autospawn line as follows:

; autospawn = yes
autospawn = no

Otherwise pulseaudio will always restart.

In a terminal, killall pulseaudio . This kills pulseaudio for your current session.

  • Thanks! This is great trick till we waiting for an official fix :)
    – wik
    Jun 9, 2012 at 0:11
  • 1
    I think this is the least repulsive of all the tricks mentioned here. Well done :)
    – mgiuca
    Jun 10, 2012 at 14:33

I've managed to get it working with sound on 12.04 in following way:

  1. Add the Wine PPA:

    sudo add-apt-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get upgrade
    winetricks directx9
  2. Change d3dx9_43 to "(native,builtin)" in Libraries tab

  3. Download windows package and install it with wine.

  4. Launch windows LIMBO!
  • 1
    Finally! This solution worked!
    – borges
    Jun 1, 2012 at 20:42
  • Glad to be helpful ;) Jun 1, 2012 at 20:50
  • 7
    Yet this doesn’t solve the issue of the Linux version failing to output sound… Jun 2, 2012 at 20:49
  • 2
    @johndrinkwater Actually, the 'Linux' version is running in a wine instance, so this workaround isn't half bad until they fix the bug in the repository.
    – MarkovCh1
    Jun 3, 2012 at 17:23

According to an email I got from the Humble Bundle support:

A new version of Limbo is being uploaded to the download pages today that should fix the Linux sound issue. Please check back on your download page for the updated timestamp below the download buttons on that page and try out the new version.

The update from the Ubuntu Software Center will probably appear soon too, as they confirmed in a second email:

Codeweavers is still finishing up the update, but we will have that posted to the download pages and the Ubuntu Center as soon as possible.

And indeed, I checked the last version that was updated: sound works fine now.


Sadly Limbo is just the Windows version with an emulator called wine bundled ‐ it is known for flakey audio. You may have to wait for them to update the release.

  • 4
    But this link says that the game is distributed along with wine just to get around the audio problems. The game uses a specific version of wine (which comes with the game), it makes no sense that this version has problems. Anyone else has this problem?
    – borges
    Jun 1, 2012 at 18:31
  • 2
    Wine Is Not an Emulator
    – Yi Jiang
    Jun 3, 2012 at 14:11

From what I can tell, the bundled version tries to talk to ALSA directly and this doesn't work while you have PulseAudio running. Simple solution: pasuspender ./launch-limbo.sh. Complex solution: make Limbo use your system version of Wine.

  • Unfortunately, the "simple solution" didn't work for me. As for the "complex solution", I even don't know how to begin.
    – borges
    Jun 1, 2012 at 20:22

Here is my workaround on getting Sound in the Linux version of LIMBO.

  1. Add your user to the audio group
    sudo adduser username audio
  2. Run a seperate xserver
    • Press CTRL+ALT+F1 and log in with your username and password
    • enter xinit -- :1 to start the second xserver
    • you can now switch between this and your regular desktop with CTRL+ALT+F7 and ...-F8
  3. run the game with pasuspender (you might need to move the mouse inside the xterm in the top-left before you can enter text).
    pasuspender /opt/limbo/launchlimbo.sh
  4. When you're done, change to VT1 with CTRL+ALT+F1 and press CTRL+C to kill the second XServer. Now you can go back to your regular desktop with ...-F7.

Download Windows version (.exe) and run it under Wine (check for it on the Ubuntu Software Center), follow the wizard, answer yes when asking for directx install and everything will work fine, I'm playing it now :)

Basically that's what the .deb package does, but doing it manually will not encounter in bugs like that.

  • I've installed the deb package previously. Now I tried this way you said, but with no result (this way the game doesn't start).
    – borges
    Jun 1, 2012 at 20:40
  • @borges That's strange what version of ubuntu and wine are you using?
    – neonboy
    Jun 2, 2012 at 12:14
  • 1
    @borges If that's not working try the Playonlinux way, check it in the repo.
    – neonboy
    Jun 2, 2012 at 12:15
  • 1
    I'm using Ubuntu 12.04 and Wine 1.4. See my accepted answer, I had to do some "tricks" with winetricks.
    – borges
    Jun 2, 2012 at 18:04

First try restarting pulseaudio:

In a terminal (ctrl+alt+t) type: (that's two minus (-) characters)

pulseaudio --kill

Then give it a few seconds to restart itself (watch the volume icon in the top right), then launch Limbo.

Limbo works fine for me with no special audio configurations mentioned in the other answers, but It (and wine in general) sometimes has issues with pulseaudio. In my case a restart of pulseaudio fixes it.

Note, you may or may not need to restart other programs that use sound (like firefox) after restarting pulseaudio.

Not the answer you're looking for? Browse other questions tagged or ask your own question.