1

When I run run abaqus2022 with abaqus job=jobname cpus=4 gpus=1 int. The following error message will appear.

USING ACCELERATOR PLATFORM_CUDA
Error initializing the CUDA Driver NO_DEVICE
WARNING: GPUAcceleration disabled

Here is the environment of my computer

NVIDIA-SMI 525.60.11    Driver Version: 525.60.11    CUDA Version: 12.0   
NVIDIA Corporation GA100GL [A30 PCIe]

i use nvidia-driver-525-open to installed the nvidia driver.

I can run pytorch with CUDA, and also can run Abaqus without GPU accelerator. And I think I set the environment variables for abaqus correctly. like:

$export
declare -x ABA_ACCELERATOR_TYPE="PLATFORM_CUDA"

I also write os.environ["ABA_ACCELERATOR_TYPE"]="PLATFORM_CUDA" # Nvidia at the end of the abaqus_v6.env file.

Can anyone tell me what is causing this error?

1 Answer 1

0

I solved this problem by consulting dassault systemes.

Abaqus/Standard analyses using GPU acceleration on Linux may fail to find GPU card. It does not find the card due to
the presence of the libcuda.so in the installation_dir/2022/EstPrd/linux_a64/code/bin directory.

Workaround:

Create a subdirectory name keepcuda in the installation_dir/2022/EstPrd/linux_a64/code/bin directory. Move the following files: libcuda.so, libcuda.so.1, and libcuda.so.418.39 to the newly created keepcuda subdirectory so that the files do not interfere with the driver installed on the system (in /usr/lib64). Note the subdirectory name is not important.

This issue does not occur in release 2021, only in R2022

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .