15

I have an issue, which I saw only on Firefox : after some time (or some event which I haven't identified yet), Firefox does not react to my mouse movement events

meaning :

  • when hovering over an HTML item, it does not highlight/change appearance even if it is supposed to do so,
  • when hovering over a clickable item, the cursor does not change,
  • when hovering over selectable text, the cursor does not change,
  • tooltips do not appear,
  • etc ...

if I trigger other GUI events (if I click, or if I press a keyboard key), then the GUI reacts (cursor changes, tooltips appear, animations get triggered ...), a bit as if, by handling that other event, firefox realized "oh, the cursor is actually there", but with no external event, my mousenter/mouseleave events seem to be ignored, or stalled.

Running Ubuntu 22.10 (kinetic), and regular firefox snap install (my current version: 108.0.1).

Does anyone have a similar issue ?


[edit] I opened an issue on launchpad, if any of you care to bring more details to it:

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/2006468

12
  • 1
    Annoys me for a few weeks already, using the binary package (not snap) on 22.04, happens since updating to 108.0. Did not find any other post mentioning it last time I searched and thought it was a my-computer issue, now it looks like an our-computers issue … Commented Jan 10, 2023 at 12:47
  • Not sure if related, I have DisplayLink drivers installed. Commented Jan 10, 2023 at 12:49
  • 1
    Same issue. When I switched from Wayland to Xorg it went away..
    – L3viathan
    Commented Jan 12, 2023 at 16:00
  • @L3viathan: did you switch back to Xorg even on 22.10 ? I have several colleagues running firefox on Ubuntu 22.10 and they don't have this issue.
    – LeGEC
    Commented Jan 12, 2023 at 16:46
  • 1
    I have the exact same symptoms running Firefox 109 on Arch Linux under Wayland. So it's definitely not Ubuntu-related.
    – aeno
    Commented Feb 7, 2023 at 9:19

2 Answers 2

7

This issue is also discussed in Firefox mouseover errors after upgrade to Ubuntu 22.04

My suggested solution is the following:

There's a bugticket for Firefox (Bugticket). If you force Firefox to use Wayland by adding MOZ_ENABLE_WAYLAND=1 to ~/.profile hover should work as expected.

2
  • tryed and that did not work for me, ff112, ubuntu22.04 Commented May 6, 2023 at 9:09
  • after adding : export MOZ_ENABLE_WAYLAND=1 to my ~/.profile my problem disappeared. So this is (in my experience) a valid workaround.
    – LeGEC
    Commented Aug 11, 2023 at 7:30
2

The only way that worked reliably for me was to add it to the desktop launcher. Exporting it globally didn't seem to work.

Copy the desktop shortcut to ~/.local/share/applications/firefox.desktop

Then edit it and add "env MOZ_ENABLE_WAYLAND=1" in all the Exec= lines. Example:

Exec=firefox %u

becomes

Exec=env MOZ_ENABLE_WAYLAND=1 firefox %u

To verify that it worked, look for Window Protocol in about:support. It must say wayland. If it says xwayland, then you missed a step.

A note from past experience: if Firefox is pinned to your dashboard you have to un-pin it, restart it and pin it back in order to pick up the changes.

Sources:

2
  • +1 for the detailed explanations. In my setup however, adding export MOZ_ENABLE_WAYLAND=1 to my ~/.profile worked.
    – LeGEC
    Commented Aug 11, 2023 at 7:31
  • Thanks! I'm on fedora, so it is was probably different. I can see the variable set when starting a new shell, but it does not change the "Window Protocol" in about:support. I was only able to get it right after editing the .desktop file.
    – Emilio
    Commented Aug 11, 2023 at 8:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .