I'm using the WiFi hotspot feature of Ubuntu 22.10, and try to connect from another Linux laptop.

Wifi connects alright on the client, but:

  • the network icon in the taskbar appears with a question mark
  • I cannot ping the internet, for example ping (100% packet loss)
  • I can ping the gateway (
  • Strangely, DNS works: dig <any domain here> works

I tried downgrading wpa_supplicant to 2.9 as suggested in this blog post (bug), didn't help. The issue persists.

Rebooting the machines doesn't help, neither does forgetting the network on the client machine then re-connecting.

Any idea what could be wrong?

  • Hi, you described your problem on a high level. Finding solutions requires low level descriptions. We need more information. My best guess: Facts: you have an internet gateway from your provider. You connected an Ubuntu 22.10 system via ethernet to the gateway. You configured a wifi hotspot on your 22.10 system, including e.g. dnsmasq for dhcp and dns Server. You have two different networks on the 22.10 system (the one to the internet gateway and second the wifi client network). Correct ?
    – dummyuser
    Jan 2 at 17:24
  • @dummyuser This is all correct, apart from the dnsmasq part, which I don't know as I'm just using the high-level Wi-Fi hotspot feature from Settings > Wi-Fi > Turn On Wi-Fi Hotspot.
    – BenMorel
    Jan 2 at 17:36

1 Answer 1


Looks like a typical basic routing issue. DNS does work as the default GW of the client is DNS Server, too. This is local traffic. Connections to the internet do not work. Even a ping from the client to the ISP Internet GW runs into a timeout. Possible Reason: (multiple issues may be needed)

  1. Is ip forwarding enabled on your gateway?
  2. I guess the ISP Gateway does not have any info about the network between your gateway and the client


  1. Enable ip forwarding …
  2. Add a route to your ISP GW for the network between your gateway and the client


  1. Implement NAT (Masquerade) on your gateway on the internet facing interface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.