0

I'm attempting to install Ubuntu on a Windows 11 pc (build 22621.963) using WSL, but I'm receiving the following error:

screenshot of error

Ubuntu was installed from the Microsoft Store.

Windows Features:

  • Virtual Machine Platform is ON
  • Windows Hypervisor Platform is OFF
  • Windows Subsystem for Linux is ON

UEFI BIOS settings:

  • Virtualisation Technology - Enabled
  • Hyperthreading - Enabled

I'm wondering if this is a Windows 11 problem? I have WSL working fine on a Windows 10 machine.

I tried uninstalling Ubuntu and in CMD ran:

wsl --install Ubuntu-20.14

Several minutes later I get this error:

WslRegisterDistribution failed with error: 0x80370114
Error: 0x80370114 The operation could not be started because a required feature is not installed.

Further info replying to NotTheDr01ds... adding some comments as I check through your suggestions, thanks....

Yes, WSL and Windows Virtual Machine enabled. Yes, Virtualisation is showing as enabled in Task Manager. In admin powershell: PS C:\WINDOWS\system32> Get-ComputerInfo -property "HyperV*"

HyperVisorPresent : True HyperVRequirementDataExecutionPreventionAvailable : HyperVRequirementSecondLevelAddressTranslation : HyperVRequirementVirtualizationFirmwareEnabled : HyperVRequirementVMMonitorModeExtensions :

Question - is Windows Hypervisor Platform required? I've tried on and off, but doesn't help. Also, I've seen in other help sources to enable Hyper-V but this is not displayed in the Windows Features on my PC. I also read something about hypervisor not being provided in Win 11 Home - I'm really confused about this.

Looking at Settings->Windows Security->App and Browser Control->Programme Settings->vmcompute ... there is not option "Code Flow Guard". I have "Control Flow Guard". I changed this to tick on Override system settings - should the button be at On or Off???

now going to reboot...

after reboot:

no change, not able to start Ubuntu.

===== Checked services.msc and lists all Hyper-V services as off. in admin Powershell enter "net start vmcompute" and check services again, this now has HV Host Service and Hyper-V Host Compete service running, other are off (I have no idea of the relevance of this yet).

but no change to Ubuntu not able to start. Will try to reinstall wsl and Ubuntu next. included disable WSL in features.

===

Reinstall Ubuntu from app store and enable wsl in windows features. Requires WSL 2 kernal update, https://learn.microsoft.com/en-us/windows/wsl/install-manual#step-4---download-the-linux-kernel-update-package

===

Getting somewhere!

wsl -l -v Windows Subsystem for Linux has no installed distributions. Distributions can be installed by visiting the Microsoft Store: https://aka.ms/wslstore

Open Ubuntu from app store, and opens a command window that starts install resulting in: Installing, this may take a few minutes... Please create a default UNIX user account. The username does not need to match your Windows username. For more information visit: https://aka.ms/wslusers Enter new UNIX username:

SOLVED

Lessons? I'm not really sure. Delete everything and start again. Ensure hyper-V is enabled in bios, windows features and services.msc before starting installaion. ensure the WSL2 update is installed.

2
  • Hyper-V isn't available on Windows Home, so Microsoft bundled up the parts that were needed for WSL2 into the Virtual Machine Platform. So so, Hyper-V itself isn't required for WSL2, but the functionality of Hyper-V that is needed should be provided by the VMP on your system. Commented Dec 29, 2022 at 14:52
  • Please create a default UNIX user account - Excellent! Sounds like we resolved it through one of those methods. My next suggestion was about to be to try reinstalling the Ubuntu distribution (after confirming the same error message - I think it probably changed). Commented Dec 29, 2022 at 14:53

2 Answers 2

1

A few suggestions:

First, double-check that WSL and the Virtual Machine Platform are still enabled after reboot.

If so, a common cause of that error is reported to be due to an incorrect setting in Windows Exploit Protection. See here, here, and here.

Check in Windows Security -> App & Browser Control -> Exploit Protection Settings:

  • In System Settings, Control Flow Guard (CFG) should be "On" (in my case, it is "Use default (On)".

  • In Program Settings, there should be entries for:

    • C:\Windows\System32\vmcompute.exe
    • C:\Windows\System32\vmwp.exe

    Both should have Control Flow Guard set to:

    • Override System Settings
    • On
    • Use Strict CFG

There are some reports that turning these off corrects the problem, but that's probably more of a "patch" than a true resolution.

Hopefully that will resolve the 0x80370114 error.

If that works, the next step I'd recommend is to install the new version of WSL directly from the Microsoft Store. That will get you on the latest version.

1
  • adding some comments as I check through your suggestions, thanks.... Yes, WSL and Windows Virtual Machine enabled. Commented Dec 29, 2022 at 13:43
0

In Powershell or CMD, run:

wsl --update

Then, open your distribution, preferably as an administrator, and update it:

sudo apt update && sudo apt upgrade

Reference.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .