I was planning to buy Acer Aspire One D270 within a few days and as everybody installs linux on their netbook I was also planning to do that.

Now, my question is how is Acer's hardware compatibility with linux and specifically in respect to the new Acer Aspire One D270.

Has anybody tried installing linux on these new netbooks. It will be a great help if a D270 user can share his/her experience with linux usage.

I read on some forums that there is some linux driver issue with Intel GMA 3600 and that people are not able to adjust their brightness. So, as I am a linux noob is this a major issue or not.


RAM : 2Gb DDR3 Processor: Intel N2600(Cedar Trail) Graphics: Intel GMA 3600 HardDisk: 320Gb 5400 rpm

  • Atom N2600 netbook ,ACER AOD270 : I tried to install 3.6.2 to linux mint13 and x org crashed after installing cedarview drm drivers. So running with LM13 with the 3.2 kernal again. any body tried magiea 2 with the 3.3 kernals ?Live usb boot flased a message about driver conflict and ran on fall back mode with 800x600. I dont want to experiment know. anybody know how to get the bluetooth working on LM13 what about installing 3.3 to LM13?
    – Rak
    Oct 24, 2012 at 18:36
  • While attempting to install drivers I got the following errors cedarview-graphics-drivers : Depends: xserver-xorg-core (>= 2: steve@steve-AOD270:~$ sudo apt-get install cedarview-drm libva-cedarview-vaapi-driver cedarview-graphics-drivers [sudo] password for steve: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. Th
    – user140875
    Mar 16, 2013 at 22:58

11 Answers 11


Oddly enough, Ubuntu 12.04 installed fine on my Acer Aspire One D270 and runs at 1024*600 - though it reports an "unknown" monitor. I installed Google Chrome, and it runs in-window Apple iTunes trailers at 480p very crisp, no stutter or other degradation.

I say "oddly enough" because when I tried to do a similar install on an Asus x101ch, which also has the Atom N2600 chipset, it will ONLY run at 800*600 no matter what I do. I did try an install of Fedora 17, just released, which is SUPPOSED to support the N2600/GMA3600, but while it installed (on the Asus) at 1024*600, I couldn't install Google Chrome at all - kept calling for software that wasn't installed, but a search through the add software program couldn't find it. (I found Fedora 17 much less user friendly, desktop, than Ubuntu, and believe it or not, I actually LIKE Unity on Ubuntu better than the other desktops I have tried (Linux Mint, LXDE, XFCE).)

I wish I could find out what voodo allowed Ubuntu 12.04 to install at 1024*600 on the D270, since I may pick up an N2800 Lenovo S110 while I am overseas and would love to run Ubuntu on it, but not if I'm stuck at 800*600 like on the Asus.

BTW I DON'T think there is software support for any of the advanced features of the GMA 3600, it seems to be running at a simple generic VESA level without any hardware acceleration, but with the dual cores of the N2600 it is ok for simple in-browser video, at least. If anybody wants me to hook up an external DVD player to see if it can play DVD's, or see if it can play h.264 rips of DVD's via Handbrake, let me know.

  • Wow that's good news b'coz I am planning to install ubuntu 12.04. I asked a similar question on ubuntu forums and one other ubuntu user claimed that he was able to run ubuntu 12.04 on Acer D270 with 1024X600 resolution out of the box. So, now I am going to buy this machine.
    – ronnie
    Jun 2, 2012 at 6:23
  • I did install Ubuntu 12.04 on the same box (the 26DKK with 2Gb that is). Everything works fine including the brightness and sound Fn keys!!!!). So I've found only one minor glitch. Sometimes the mouse arrows disappears if I am above a clickable button. BTW Ubuntu suggested 2 proprietary drivers. One for the Wifi and one for the video card.The video drives had the name "Cedar View" .
    – robertnl
    Sep 25, 2012 at 20:29
  • You need to install the mesa-utils package for the graphics card+driver to show up in the system utils information tool.
    – MagicFab
    Dec 1, 2012 at 22:20

(I'm not english speaker-writer, but give me a chance)

I'm using ubuntu precise (12.04 LTS) in my AOD270. Everything is right for me except the video (VGA, HDMI) output. Fair to say that I do not use quite much graphics and that's almost the only issue that I've noticed (on about 3 weeks of using it with Precise Pangolin) and obviously must take more than the output (the only thing that I care about video). Anyway, if I connect the external monitor before turning on the netbook it works as it only has the external monitor (showing a distorted mirror image in the netbook screen).

So it has the issue of the GMA 3600 (output, brightness, 3D, etcetera...), but I've used the rest of the hardware (WLAN, USB, audio, touchpad, etc...) and it works fine. It would be better if while installing you have a LAN conection, in case that you need some [privative] drivers from the intenet before using WLAN (STA Broadcom).

Right now I'm downloading MeeGo, for installing aside Ubuntu Precise and W7; because I read that it has drivers for de GMA 3600. I've seen other user's commentaries about changing successfully to MeeGo. I think to do it partially, just for using the video outputs, and until ubuntu or another similar linux distro have better perfoncance with the Atom N2600 and the GMA 3600.

The other general and I think minor issue is that maybe Ubuntu 12.04 run quite slowly in AOD270 (no more than W7 anyway) because of Unity. But is something of taste I think, and you can always try Xubutnu and Lubuntu.

If you hasn't buy the netbook yet, maybe an Asus [or Lenovo] is more friendly hardware for Linux.

Finally I insist: Ubuntu 12.04 works fine in my AOD270, except the known video issues.

Hope this to be usefull. Manuel.

  • Thanks for the reply. I also read that people are not able to run linux on their D270 on full resolution(1024X600) and because of the GMA3600 they are stuck with 800X600. So, is there any solution for the above problem or I will be stuck at 800X600 till the linux supported drivers are not out.
    – ronnie
    Jun 1, 2012 at 5:37
  • So, are you running on full resolution or 800X600.
    – ronnie
    Jun 1, 2012 at 5:38
  • I would have bought asus or lenovo but I am actually from India and where I am living asus and lenovo comes with 1Gb RAM only.
    – ronnie
    Jun 1, 2012 at 6:14
  • As for MWebb, the resolution hasn't be a problem for me (indeed, I'm "stuck" at 1024*600, i.e the full resolution).
    – manueltts
    Jun 2, 2012 at 19:11

I installed Linux Mint 13 (based on Ubuntu 12.04) on my D270, and the monitor booted at maximum(or very high brightness), and the fan is continuously running at a high speed. No resolution problems though.

The monitor problem I could easily fix by entering in the terminal:

sudo setpci -s "00:02.0" F4.B=35

I ended up adding this line to /etc/rc.local to make it automatic instead of having to change the brightness in the terminal for every session. Change the number at the end(in my case 35) to a lower value to decrease brightness and vice versa.

Now I have to figure out how to stop the fan running at full speed, because it is loud, and unnecessary when the machine is idle. This will no doubt wear out the fan bearings too. Will update when I can find an answer.

  • So, you found any solution for the fan issue.
    – ronnie
    Jun 27, 2012 at 13:48

Install Intel binary Xorg driver for GMA3600 (Cedarview) GPUs!

a). still not full performance but works with 2d acceleration and I could play 720p videos with out problem.

b). Adjust brightness with Fn Keys Work!

How to do?

  1. First install generic kernel, reboot and and make sure you're using this kernel:

    sudo apt-get install linux-headers-generic linux-image-generic
  2. Remove pae kernel with their respective headers & reboot at the end of this:

    • sudo dpkg -l | grep linux-image (This will show kernels on your system)
    • Remove all package related with pae kernel: sudo apt-get --remove purge "name of package"
    • sudo dpkg -l | grep linux-headers (This will show headers on your system)
    • Remove all package related with pae headers: sudo apt-get --remove purge "name of package"
  3. Install the cedarview drivers:

    sudo apt-get install cedarview-drm libva-cedarview-vaapi-driver cedarview-graphics-drivers
  4. Update the Grub Bootloader

    sudo update-grub2
  5. Reboot the System and joy!

NOTE: can activate 3D acceleration test, to see if it works. For this,change Option "AIGLX" to "On" (default settion):

sudo gedit /usr/share/intel-cdv/X11/xorg.conf.d/61-cdv-pvr.conf
  • My lspci | grep -i vga output is 00:02.0 VGA comaptible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09). So, is this not Intel binary Xorg driver for GMA3600 (Cedarview) GPU?
    – RanRag
    Aug 23, 2012 at 20:59

I am a new to linux. I removed the Linpus linux that came along with ACER AOD270 Atom N2600, Intel GMA3600. It runs on Cedar Trail platform (I am not a techee) and intel has incorporated the drivers with their own linux distro Meego 1.2.

I've tried Ubuntu 12.04 and after installing couldn't adjust the brightness. But after updating it showed to install additional drivers and installed the Cedarview drivers. Those crashed after some time, without much problems and now I am very happy with Linuxmint13. Searched the synaptic for cedar and installed 4 softwares for cedartrial and cedarview and I played a movie 1920x800 nicely. For adjusting brighness , the Fn+ arrow keys worked well. Additional brighness reduction was achieved with RedshiftGUI

  • Its nice to hear that people are able to work with GMA 3600.
    – ronnie
    Oct 21, 2012 at 19:02

Okay, I too have an AOD270, and I live in India. So basically everything works except brightness controls and 3D acceleration (so no compiz and other such pretty effects).

Brightness can be adjusted, although only from Terminal. Other than the display problems, I am absolutely loving this netbook.

  • Thanks for the reply amol. I am not looking for 3D acceleration because I will be replacing unity/gnome either with xfce or lxde. I want my distro to be as lightweight as possible.
    – ronnie
    Jun 3, 2012 at 7:00
  • I believe display problems doesn't means that you are stuck at 800X600 resolution.
    – ronnie
    Jun 3, 2012 at 7:02

I managed to make an Eeepc 1025c work almost perfectly (including full video acceleration - 1080p at 10% CPU or less) on Lubuntu 12.04 and wrote a guide about it. Hope it could help:


It should work on similar hardware and different ubuntu variants/derivate but I couldn't check; I hope I get some feedback about it.

  • Thanks mate. Your suggestion to install vaapi-mplayer worked like a charm and now I can see videos at 10-20% CPU Usage.
    – ronnie
    Aug 27, 2012 at 12:57
  • Which ubuntu variant are you using? CPU use seems a little high to me, at least compared to Lubuntu Aug 27, 2012 at 15:48
  • I am using ubuntu 12.04.
    – ronnie
    Aug 27, 2012 at 15:52

This week and last week I've put Ubuntu Netbook Remix 10.04 on two D270 Aspire Ones (1Gb RAM) for friends. This has been updated to current Kernel, etc. Installation was quick and painless from USB stick.

Resolution is 1024x600, no problem here, however brightness is fixed level (not a problem) and card reader does not work (needs a driver). The only other quirk I've found is that on wireless connection the icon in top panel does not show an active connection state but reverts to the red ! symbol (proprietary driver downloaded). There is also no 3D, although on a cheap netbook again this isn't really an issue.

Overall it runs well, as does my old faithful ZG5, and is a big improvement on the Win 7 starter that came installed (I've left this on as a dual boot 'security blanket' for Linux newbies). Nice little machine, super keyboard and loads of battery capacity. Enjoy!


I also have mint 13 (kde) running on my d270. You should not try to update the kernel. The cedarview driver patch packages only work for 3.2.whatever it is. The kernel and headers should have been held. It doesn't really work as well as it should but linux is robust enough that it works.

I'd be using kubuntu except ubuntu based mint uses an older release, so synaptic was able to do all the configuration for me.

As of now I'm waiting for the official 13.04 kubuntu release. I tried the alpha 2 but I don't have the recovery skills to deal with pre release linux. But ... before the 2nd or 3rd update it worked very well. I expected an update to bork the system. It wasl alpha.


I've installed Ubuntu in Acer Aspire D270, and here are a few things that I experienced.

1) Only Ubuntu 12.04 runs well. (I could not install Ubuntu 12.10 well. And I could install Ubuntu 11.04 or 10.10, however I could not use Wireless Internet. 13.04 beta might be working better than others.)

2) Updating everything is a bad idea in my case. (I once updated everything, and I found somehow Ubuntu failed to load my SDHC card reader, which worked well before updating.)

3) Intel GMA 3600 graphic chip is not supported properly. (I could not use any 3D graphics and Open-GL well. There was one recommended driver, but when I installed it, it made my graphic even clunkier. I just gave up to use.)

4) There was a screen brightness problem, and I could fix it. (It was too dark, and I could not control with my keyboard. I should have used "sudo setpci -s 00:02.0 F4.B=40" command in terminal. I just put this command in a script.)

5) There is a sleep/suspend/hibernation problem, and I could fix it. (It slept well, but when it turned on again, it showed crashed screen. I should have used "pm-suspend --quirk-dpms-on" command to suspend the system. I wrote a line of code to a file in /etc/pm/config.d for a little automation. )


I found these indication on webpage: http://nikunjlahoti.com/2012/04/29/ubuntu-12-04-fix-fn-brightness-keys/#comment-672 Strangely enough they also fix the sleep/resume problem.

Open as root the following file: /etc/default/grub

$ sudo gedit /etc/default/grub
[sudo] password :

Insert the text: acpi_backlight=vendor, so that the line becomes:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi_backlight=vendor“

save and close your editor. Then update grub, by running in terminal:

$ sudo update-grub

It will tell you something like:

Generating grub.cfg …
Found linux image: /boot/vmlinuz-3.2.0-24-generic
Found initrd image: /boot/initrd.img-3.2.0-24-generic
Found linux image: /boot/vmlinuz-3.2.0-23-generic
Found initrd image: /boot/initrd.img-3.2.0-23-generic
Found memtest86+ image: /boot/memtest86+.bin

After that just reboot the machine.

$ sudo reboot


At times the screen would go entirely dark. Or would not apparently resume from a blank screen or when the screensaver gets active.

For such cases, all you need to do is press “Fn + Brightness UP button” and screen will GLOW. Simple!!

To suspend, just press Fn + F4 (Z') button. It works on my Acer AOD270

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .